Rangefinder connected to Can port on pixhawk

Hi , i am trying to setup my TF mini plus lidar connected via the can port instead of i2c because I already have my gps connected to i2c . I tried activating the can protocol and selecting RNGFND1_TYPE to 24 but still I get the error : Rangefinder 1 was not detected. ( I just want to mention that for now I don’t have a battery so maybe the rangefinder isn’t detected because it couldn’t power up with the usb cable from my pc ? )

Please update to the official stable ArduCopter 4.1.0 release and retest with a battery connected.

Ok but are you sure it is just a battery problem ? Because i have to wait at least 2 weeks for my battery to arrive so if the problem can be solved without it, it will be a big gain of time .

No, I am not sure. But if I were you, I would get a power supply and test it with it.

Ok thank you, I will wait for my battery then

Any other suggestions ?

Do I miss something or why should the TFmini plus work over a CANbus connection? As far as I know it can be connected over I2C or UART (at least mine does…). The connector might be the same, but that is all.
You most likely do have the compass connected to I2C, not the GPS. Use a I2C splitter to connect the TFmini and the compass to the I2C port.

1 Like

Good day, if you want use tfmini as can periph you need a board called can node that can convert serials periphs or i2c periphs.
You can look for Mro can node it’s equipped with the F303.
My setup was tf mini but also the retired teraranger one can work on it

see my post 15

Range Finder Greyed out - #15 by smartdave

1 Like

Hi thx for your reply , i do have a I2c board , I tried to connect the gps ( The compass from the gps ) and the lidar but I get an ‘Internal error x 0.800000" , ‘Compass 2 not found’ and "Rangfinder 1 was not detected’ So i need to figure out how to tell the pixhawk that there is 2 device on the i2c port

Thx but i need to solve this without other components because where i live there is no amazon or aliexpress so i need to wait months for something to arrive

Well, an i2c periph will never work directly connected to the can port of your fc.
About the error to you encounter… check the correct wiring and if you are using the i2c rangefinder better power it with an alternative power source… you can use a ubec.
When you are using i2c periphs just check they don’t have the same address… you will have conflicts

how to i check if they have the same adress ?

check using MP under HWID

ok i opened the HWID page :

( I have to compass and Rangefinder plugged in ) ( and without a battery idk if it important because maybe the lidar can’t be powered by the usb from my pc)

And here’s when i unplugged the I2c board that contains the compass and the rangefinder :

I suggest to power the lidar with an alternative power source
HWID seems correct.

so i need to get a battery i guess

You don’t need add an extra battery… for supply extra periphs like rangefinders… telemetry… etc, just use an ubec coz the fc cannot provide enough current to all of that

1 Like

but if i get a battery for the drone and plug the lidar and compass to the i2c board and then the i2c board to the i2c port on the pixhawk it might work ?

as previously said i suggest you to use an ubec for supply telemetry module… rangefinders and other extra periphs.
You can also supply everything without it but limiting the operation.
Gps module with compass can be powered directly by the fc… uart port can handed it.

1 Like

So the rangefinder can be powered be the i2c port if I get a battery but it is better to wire the positive and negative wire to the pdb?