Rangefinder behaviour. Remove "jumping" obstacle feature

Hi everyone.

We have a 4" drone with Matek F405 miniTe, ardu 4.2 version and Matek optical flow & benewake tf mini rangefinder.

The drone flies perfectly, althold perfect, loiter indoors perfect but there is a feature that can be a problem.

when the rangefinder see an obstacle, the drone ascends. these feature its very strange in comparation with similar comercial drones with downfaced rangefinders.

when you flies indoor and you can move the drone in very closed spaces, these “jumping” feature makes more dificult the flight, being very carefully with the throttle control to down the drone when sees and objetc.

there is any way to disable this “jumping” feature of rangefinder?


1 Like

you need to make AVOID_ENABLE = 0 to remove the loiter mode avoidance feature, so your copter won’t rise when something appears below it in the way.

1 Like

i had disabled the avoid feature and the copter have the same behaviour in altholt mode.

there are any form of deactivate the avoid feature in althold mode?

in our drone, the althold mode its the principal flight mode, loiter use only to brake and mantain position.

Setting AVOID_ENABLE = 0 will only disable simple avoidance. Simple avoidance does not use a downward-facing rangefinder for obstacle avoidance.

@PVR2022 what you are probably talking about is surface tracking: Surface Tracking — Copter documentation

You can disable it via AUX switch as written in the documentation.

yes sorry my mistake it won’t solve the problem so you are right it should change the pitch tracking

we only want to use the rangefinder to make a constant height. not for surface tracking.

if i disable the rangefinder via rc switch, the height of the drone its controlled by the baro?

@PVR2022 that’s what surface tracking does… it uses the rangefinder to maintain a constant height above ground
If you disable surface tracking, then altitude will be maintained by EKF’s altitude… i.e the combination of barometer, IMU etc…

how to cancel surface tracking?

disabling the rangefinder via rc stick?


Not sure if this is what you are looking for but there is an option under RCx_OPTIONS that allows you to enable/disable surface tracking Up/Down…

1 Like

We have test the surface tracking up down off by rc options and the drone have the same behaviour.

there is to change the ek3_src1_posZ values?? at the moment, this parameter is set to rangefinder source