Random servo movement Q-plane


I have random servo movement in all guided modes (FBWA, Qstabilize, …) manual work fine.

  • PH 2.1 Cube (FW 3.9.4; also tried on 3.9.3)
  • High performance Futaba servos (BLS 177 SV)
  • Servos are on separate power source

I have run out of ideas, any help is more than welcome.

Are the servos direct to the pwm rail, or via sbus-out?
A log might be helpful by the way.
Side question: what GPS is that?

I forgot to mention the main thing, servos are moving weird only when GPS lock is established.
Servos are connected direct to pwm rail. I have also tried different brand servos with the same result.
GPS, there are 2 Here in a custom casing.


I think this is fairly common, its just the gps signal bouncing about a bit, should stop one you move forward at any-speed.

i.e. if the gps lock is accurate to 1m or even tens on cementers when the aircraft is stationary this is seen as rapid changing direction of the velocity vector. Once you move forward a bit the inaccuracies are much smaller than the velocity vector and hence no twitchy servos. You should see it smooth out even at walking pace

Peter thanks.

I was thinking the same way, but till now on smaller (and lighter) VTOLS I have never seen servos moving so much. This one is much bigger (4m w-span and 30 kg) with a lot of carbon also…
I will try at walking speed first and some additional shielding under gnss and i will also enable logging at start without arming.

Just one another question not related to this topic.
Is there any difference in FW (on ChibiOS) between CubeBlack and fmuv3 for PH2.1?

essentially not,

its just some usb vendor ID stuff and a change to two ADC pnis

Hello friends. I’m having the same problem, my traditional VTOL quad plus the rear engine airplane. The servos quit on and on when I connected the battery, I tested another servo and the same problem. The strange thing is that they stop picking when I take the quad motors off the PWM rail. I already tested without connecting the escs of the quad and tremble alike, it is not an ineference of ESC. I thought of mapping the channel 1 and 2 ports to auxiliary ports 10, 11. My impression is that the channels connected to the servos respond as if they had motors there. Any idea how to solve it? I’m with firmeware arduopilot 3.7.1