Ramp function for acceleration

I want my rover to slowly start it’s acceleration! Like ramp from 1 to 100 very slowly like in 6-10 seconds even when I suddenly push it to full throttle!

My rover has 2 t100 thrusters!

Any kind of help would be great!

Have you experimented with ATC_ACCEL_MAX?

1 Like

MOT_SLEWRATE will achieve this for you:


1 Like

By the way, the difference between these two possible solutions (listed above) is one limits the desired speed while the other limits the resulting throttle output. Either should work but personally I would tend towards using ATC_ACCEL_MAX but it’s up to you.

Thank you @jimovonz!!
If I’m using the MOT_SLEWRATE, it has a value of 0-1000. What does 1000 do and what does 0 do?
What is the increment parameter in it?

Thank you @rmackay9!
How to use the ATC_ACCEL_MAX?
this has the value and the increment!
What should be the optimum value to result in a very slow acceleration in the manual mode?

Not yet @David_Boulanger!
Will do now.


The ATC_ACCEL_MAX is only used in modes where the speed/throttle controller is active which is all modes except Manual mdoe. So for Manual mode the MOT_SLEWRATE is all that is available.

For reference (you’ve probably already seen it) here’s the parameter description for MOT_SLEWRATE:

Throttle slew rate as a percentage of total range per second. A value of 100 allows the motor to change over its full range in one second. A value of zero disables the limit. Note some NiMH powered rovers require a lower setting of 40 to reduce current demand to avoid brownouts.

So a value of 100 allows the throttle to go from 0 to 100% in one second. A value 1000 allows the throttle to go from 0 to 100% in 0.1 seconds. So a lower value should make it respond more slowly. For example a value of “10” will mean it takes 10 seconds to reach 100% throttle. Note that it will also likely take 10seconds to get back down to zero.

1 Like

Hey @rmackay9,
Ive searched a lot for MOT_SLEWRATE. really not able to find it. I’m using an APM 2.8
Is it because of this that I’m not able to see that parameter?


Ah, right. We stopped supporting the APM boards almost 3 years ago. It’s best to get a more modern flight controller. Personally at least, I can’t provide support for these really old boards…

I learn something new every week!