Servers by jDrones

Radiomaster TX16S + RFD TXMod Sbus

I’ve been struggling to get sbus working on the RFDesigns TXMod attached to the back of my radiomaster tx16s. I’ve seen a few posts here and followed the loosely relavant instructions but haven’t gotten very far. I’ve got the RFD900ux on the air side. I’ve tried to set Sbus in to 4 for the radio side but that didn’t work, tried the other sbus options but still nothing. Has anyone got a similar setup and got it running? Any advice would be greatly appreciated! I can use PPM but the 8 channel limit is too restrictive

I’m using the same setup (900x not ux, but close enough). I think I’m using 9 channels, but I have 12 available. Probably the biggest pain I had getting it going (next to fail safe), was getting the airside radio updated. I’ve got both radios on the 3.16.

The instructions from RFD are complete… They just aren’t very well laid out and there’s a lot of things you need to dig for.

My suggestions: Get the latest firmware on both radios, then use the setup wizard to get it all setup. I’m normally not a fan of setup wizards, but in this case once I updated the firmware, it seemed to work. And don’t trust that the failsafes are setup correctly until you’ve tested them every possible way you can think.

I don’t profess that the settings I have shown here are the best and you should use these. These are mine and so far they’ve been working for me. But like everything, subject to revision. Your milage may vary.


2 Likes

Thank you very much! I’ll give that a try tomorrow. I need around 12 channels so your setup is perfect for me, didn’t realise PPM was capable of more than 8 but good to know otherwise!
Regarding failsafes, did you use the set ppm failsafe button? I’m thinking of setting it so all sticks are centred, arm switch is enabled and flight mode set to RTH

I know some have had issues with setting up the failsafe using the failsafe button, but it worked for me. I almost got caught out because I was connecting to my air radio by USB, and using the radio to link to the TXMOD unit. So that means the air radio looks on the screen as the “local” and the TXMOD is the “remote”. If you’re doing the same, then you set the failsafe on the “local” radio.

You can set the switches and sticks as you’ve described and it should work. But the problem is the pixhawk will not actually recognize there’s a radio failsafe. So it just thinks you’ve hit the RTL switch and called it a day. The RFD radios don’t actually send a fail signal to the Pixhawk. The only way the pixhawk would see an RC Failsafe is if the air radio were to fail. If the failure is on the TX16S/TXMOD side then your air unit will just send the failsafe configuration you’ve setup above. The end result is hopefully the same, that your drone comes back, but if you want the FC to recognize a failsafe condition then I posted a work around. The link is below. So far it’s held up to my ground testing, and nobody has piped up to say that X, Y, or Z is wrong and it’s a bad idea.

https://discuss.ardupilot.org/t/opentx-rfd900x-txmodv2-failsafe-workaround/63054/4

1 Like

Okay brilliant, thanks for all your help!

Hi, your set up works well for me, including the failsafe workaround you suggested. Tested on bench, so far so good. Thanks again for your help!

Great to hear! Glad to help.

If you do notice anything strange about the failsafe work around please share it.

1 Like
Servers by jDrones