Radiomaster R161 and Yaapu

Hello everyone the last days i build my newest Quad and everything works fine except the telemetry over Yaapu.

My Setup:

  • TX16S with EdgeTX 2.8 (4-in-1 Module Firmware
  • Yaapu Widget 2.0.0 beta2 (commit d23ad61)
  • Mateksys F405-Mini TE
  • ArduCopter version 4.4.0

My SBUS is working fine using the Sbs Port (UART 2) on the FC.
For my Smart-Port tried almost everything.

My last attempts were connecting S.Port over an self soldered inverter with the 74HC04 IC (and a diode 1N4002) and also using the hacked uninverted S.Port of the R161.
I can clearly see that the uninverted S.Port is correct.

This is the inverted output (exposed on the JST Connector)

I used UART6 for each try, but also already tried i.e. UART3.
The Serial Protocol i tested 4 (Frky S.Port) and mostly 10 (Pass-through).
Baud Rate was everytime 57.
Because of the F4 FC i don’t really have any serial options. When connecting the hacked S.Port I set it to HalfDuplex and connected the wire to UART6_TX. In case of the inverter i don’t used any options and connected RX and TX to the IC. Weirdly i don’t had any signals on the TX line coming from the FC.

My Receiver can discover 5 Sensors A2, RSSI, TRSS, TQly and RxBt. The Yaapu widget says no telemetry data.

I am currently completly lost and really don’t know where i should start to dig deeper.

Alright first update:

This is working now. It’s my first Matek FC and the ArduPilot Mappings are different. UART6 != Serial 6. Using the converter still no success. Trying everything else again.

Using the non inverted pad and connected to UART6 (Serial 5) with the following settings

    still no success. Can’t discover new sensors. Yaapu Debug Script has no data.

This is the Half Duplex Signal

Maybe ping @yaapu? :sweat_smile: