Radio telemtry not getting parameters

I have a Mini APM 3.1 with radio telemetry and MinimOSD connected. I have 3.4 firmware installed. When connecting to Mission Planner by USB all is fine. However, when connecting by radio, it gets the telemetry data but will not fetch the parameters. It could be left for ever but not getting them.
The radio setup appears to be good. RTS/CTS is unchecked. I have tried disconnecting the MinimOSD, this makes no difference.
Can someone please offer a solution?

I have now tried installing different firmware, i.e. plane. This made no difference. I then reverted to copter v3.2.1. I now have no telemetry at all. The Mavlink connects but returns nothing in Mission Planner.

I have also tried to reset in Terminal, however, when connection it immediately starts reading the Mini APM config. I can’t enter setup to perform a reset. I also tried ‘Reset to Default’ in MP ‘Full Parameter List’ this didn’t enable Mavlink. The 3DR radio is good, I’ve tested on another copter. The OSD shows ‘No Mav Data’.

I am totally stuck now with no other options I can think of.

Is there any other way of resetting the APM? I want to get it back to the factory defaults, and start from scratch again.

Please help if you can!

My latest is this: If I install Plane or Rover firmware I then can get Mavlink telemetry data in Mission planner, but not parameters. I achieved this by unplugging all ports from the APM, except USB of course.
However, when installing copter 3.4 again, with ports unplugged, there is still no Mavlink data although it connects at 57600 Baud.
It doesn’t seem logical. I can only assume that the EEPROM or flash memory is retaining some code that prevents Mavlink from sending copter data. This is why I want to completely clear the APM of all code, for a fresh start. I tried clearing by using the Arduino IDE, but no success.

This sounds like a wiring issue. It sounds to me like you’re able to receive but not send data to the APM over the telemetry link. The MinimOSD is suspicious, I know the wiring harness for it sometimes disconnects the Tx pin so it can share a serial port with the telemetry radio. Does it use the same connector type for the MinimOSD as it does for the telemetry module? If so, I’d swap them. If that doesn’t work, I’d double check the wiring and make sure Tx and Rx are both properly connected between the radio and APM, maybe even probing the solder points on the respective boards with a meter to ensure there’s continuity all the way through.

Thanks for the reply. It isn’t wiring or hardware causing the problem. As I previously said; if I install Rover, Plane or anything not Copter, the telemetry works over Mavlink where I see all data in Mission Planner ‘Flight Data’. What I don’t have is fetching the parameters; I can live without that. Then if I install any of the copter firmware, including helicopter, Mavlink connects but returns nothing at all in MP.

When I first installed Copter, Mavlink was working in that I had data in the ‘Flight Data’ screen, but not the parameters. I read on this forum that if I installed a different firmware such as Plane, then re-install Copter, that any problems may be resolved. But no, it made things worse. In retrospect, I should accepted it as it was without parameters over Mavlink.

There has to be residual code in flash memory that prevents Mavlink from working properly. This is why I really could do with getting the APM back to factory defaults, but the normal methods don’t work.

I forgot to say, that if I disconnect the MinimOSD, so only the 3DR radio is on the telemetry port, it connects but nothing returned. When I installed the other non Copter firmwares, I had Mavlink data with the OSD connected, which output the correct data to the video monitor.

Today, the Mavlink connected first time and output data in Mission Planner ‘Flight Data’. So I could all the usual telemetry info. Great I thought, it’s working at last. However, when trying again for several times, it would connect but no data again.
I then looked at the Stats and saw that a lot of packets were being lost. The image below shows 117 lost packets immediately after connecting. This appears to be the problem. But why is it happening with Copter firmware, but not with Rover, Plane etc.

Try to flash new firmware to each tellemetry from mission planner

I had once this problem and this save the day

I have it sorted out now. I downloaded the params from my hexacopter and uploaded them to the quad. It now all works correctly. I still don’t know which parameters were wrong though.
Thanks for the input.

I have the same stuck to getvparameters. I have an Hexa. I don’t know how to solve the issue.
Compare to you, I have no other file to download.
Thanks for your help.

How do you flash new firmware from mission planner? I use a RFD900+. But i have similar issues, the getting params irrespective of plane/rover/copter.

Thanks in advance.

I had the same problem as a topicstarter has and I solved it. PixRotor (very rare “roc-drone” fc), FW AC3.3 and 3.5 and 3.6. It was my mistake which cost me a whole day. I connected flight controller TX to modem RX but missed modem TX to FC’s RX and put it to RTS or CTS. There was all flight info on dashboard but there’s no parameters, and connection process always stuck at “Getting Params 1”