Radio telemetry linked but not able to transmit

I bought a hextronik telemetry 433Mhz kit and it being impossible to link,

The green led is solid when both units (the ground station and the air or conected to the AP2) and if i disconect one of then the green led start to blink so they are conected but the mission planner is not able to connect with the air unit

I tried all the baud rate possibles but no way

I tried to upload configuration in the mission planner sky radio configuration menu and here comes out some suspicius things

The ground or usb unit is able to be readed and uploaded by the mission planer but not the air or remote unit, I tried conecting the air unit by and FDTI cable to the computer usb and setting the mission planner com port as the FDTI detected but there the mission planner message is “failed to identify radio”

I try even downloading the I3dr radio config tool and happends the same the usb uni upload perfctly but the air unit no way to upload…

I´m geeting desperate… someone can tell me how to fix this issue?

Thanks for your time

I thought both those radios have USB ports on them. They both should work at 57600.

If the Tx/Rx are wrong with the FDTI cable it won’t work so that could be the issue with the remote side. Otherwise they both should work with USB cable.


There are 2 units, the one connected to the computer (ground station part with an usb connector) and the one connected to the Ardupilot which has not usb (just the pins without the fdti chip) is why if you want to configure or set up the air unit (the one connected to the ardupilot) you need the usb to fdti cable.

I tryed to switch rx and tx positions but… the same, no working so unfortunatly the solution was not that simple

thanks for the suggestion


The ones I have and these at hobbyking are interchangeable.
HKPilot Transceivers


Hey Hugo,

Did you manage to find a solution to this???

I believe the problem is with the Pixhawk and powering on the unit. The unit goes into config mode and does not come out of it with these units. I think another thread here covers this problem and even has a work around to make it work.


HI Hugo I’m Joseh I hve the same problem that you have link solid green led but no communication.
but in my case i have both radio communicate and message “success” .

I did I open MP connect my radio. in 3D page i set both radio at 11XXX then load setting next i be sure i have success communication in both i adjust ground station to 57600 copy and save it , i make sure that the success message show up.
then in the main screen i set the rate to 57600 and link, but i have nothing show in the status and I can see all information in both radio.

do you find out?

Hi Joseph!

I was able to turn the unit to configuration mode through terminal and once they are in this mode I´m able to set every parameter related with the radios configuration. Are you familiar with using a terminal as interface with the radios? are you using mac, linux or windows for this?

If you want I can give you the list of parameter and values and so you can configure your radios as my ones, are you operating in Europe (433MGhz)?

Also to tell you that some times the problem comes from the FDTI windows driver and the configuration of this USB to TLL converter… I had many problems with it, sometimes I got an FDTI not able to get the baud rate of the configured radio and other times was the windows driver…

But finally through a terminal I managed to configure both radios and to make them speak perfectly to each other!

Thank Hugo Well I never used terminal but I am very software and hardware skill to go into it, I just start to play with this micro controller to build a Rover, I am in USA and my telemetry is 915MHz. please let me know what I need to do. so I can get into this, i buy a second set of telemetry thinking that I damage it, but the same problem I don’t see the data transfer when l link the unit. it work one time but never more.

i have win 7 and win10 Pro. i use different Pc but the same.

i found a web side with some driver update but nothing happen
I am out of the country, programming a job returning tomorrow, I want to have some time to play with that, but i take 6h to get home with the time from airport to airport.

Ramos is latin or italian?
thank Hugo.