Radio failsafe issue with R/C Taranis transmitter as a joystick

Hi at all,
we are testing the Skydrones Airlink Core autopilot with the Arducopter firmware version 4.4.0 (for Airlink board) but we are facing with an issue relating to the “Radio Failsafe”.
We tested the newest 4.4.3 firmware version also but the problem is the same.

In detail, we don’t use a R/C receiver connected to the SBUS channel but we use a Taranis R/C Transmitter as a joystick (connected to a PC via USB cable) and all the main RC channels are in the correct range (between 1100us and 1900us) when we check in the Mission Planner “Radio calibration” page.
After we completed all the initial calibration (IMU, compass,…), joystick enabled
and switched to “Stabilize flight mode”, when we try to arm the drone immediatly we receive an “Radio Failsafe” error as you can see on the following picture

(we have the following “Arming check” enabled).

Our radio datalink is stable and works fine and never the PWM THROTTLE signal decrease under the default Radio Failsafe threshold (975 us).
if it had been a radio problem, it would have occurred even before the arming check control.
Furthermore, if we disable the arming check control the problem desappear and we can arm the motors but this is strange becouse we should see the radio failsafe problem anyway.
We tried the following options also but the problem is the same.

For us is mandatory to enable the “Arming check” control to increase the safety level.

We tried to change the joystick (R/C Transmitter) with another that we know that works well but the problem remain.
We tested the same 4.4.0 firmware version on Cube Orange autopilot (for Cube Orange board obviously) and all works fine.

Could someone help us to solve the problem ?
Thanks for your time and patience.

Try FS_THR_ENABLE set to zero.

Have a look at this page: Operation Using Only a Ground Control Station (GCS) — Copter documentation

I Allister,
sorry for the late reply.
I tried to switch off the FS_THR_ENABLE parameter and it seems work fine.
It seems that when FS_THR_ENABLE is enabled and the RC IN input pin is floating (not connected) it can catch some elettromagnetic noise that force a Radio Failsafe error.
So, at this point i faced with another problem.
When we are flying (with Taranis as a Joystick) and FS_THR_ENABLE is disabled, if we disconnect the usb cable from the Taranis controller, the RC input on “Radio calibration page” keep the last stick value and no Radio Failsafe is activated. Maybe i can act on the change mode button on the “Action Tab” on Mission PLanner but i’m searching for a way to engage the RTL automatically in this situation (when i disconnect the usb cable from Taranis).
Is it possible to write a LUA script that can read the joystick status (Disabled) and automatically switch on RTL mode ?
Thanks at all.

The FS_THR_VALUE must be at least 30 below the normal minimum throttle level.
So if your throttle PWM normally goes as low as 1000 (for example) then FS_THR_VALUE would have to be less than 970