Radio Failsafe configuration on mission planner

Hello,

I have the following configuration:

  • Taranis Frsky X9D+ as transmitter

  • Frsky X8R as receivier

  • Pixhawk as Flight controller

I have followed a few pages on the web to set the proper configuration, basically this is what I have done:

  1. set the transmitter failsafe mode to receiver

  2. set the receiver failsafe mode on option 2, as expained on its manual, and in this arducopter page..

  3. Set Radio failsafe on mission planner.

I have a few doubts about:

  1. value for FSPWM [FS_THR_VALUE]? Must this value be set only if I had chosen Receiver failsafe option 1? As to option 1 I am referring to the low-throttle method, as stated on the arducopter page.

  2. I have performed all bench tests from test 2 to test 5 as described on the arducopter page, they all work perfectly. Only Test 1 doesn’t work, is it due to the fact that it should be tested for the low throttle method only?

Best regards

You are correct. Test 1 in the wiki will only succeed if you configure your equipment and parameters to utilize the throttle channel low method. If you are not using that method of failsafe, you can ignore that test step.

In the code, you can see here is where it detects the lack of any update from the RC receiver, as in when configured for no pulses. And here is where it detects the low throttle value from the receiver.

Thanks Matt for your reply,

would you agree with this configuration? or would you rather the throttle channel low method?

Bests

Either is just as reliable, so what you’ve configured is fine. I think no-pulses is generally recommended.

Dear Matt,

I need to deepen some topics, any further insight it is very appreciated.

Insights:

  • is it right to set the trasmitter failsafe mode to receiver? There are other options such as Hold, Custom, No pulses. I feel to have picked the right choice but I need you to share your opinion about it.

  • The wiki page states: when a radio failsafe is triggered if the copter is disarmed no failsafe will take place. I have to disagree with this statement since The Red Text Failsafe got displayed in the monitor. Do you get the same issue?

  • The parameter FS_THR_VALUE is used only for the “low-throttle method”, is it right? Since I am using the “no-signal method” this parameter can not be considered, do you agreee? is there a value which disables this parameter?

  • As to FS_THR_ENABLE parameter I have Enabled Continue with Mission in Auto Mode (which is Deprecated in 4.0+), the wiki page tells to use FS_OPTION, actually I have not understood how to configure this parameter, do you have any tips?

This is TX/RX make/model specific question. I don’t know what you’re using for equipment and I’m not familiar with it’s settings.

This is expected. The receiver is still lost and the GCS is telling you. And you can’t arm in such a state. But no actions are being taken related to the failsafe.

Yes you can ignore it. No there is nothing to disable with it. It is not used.

Please see the wiki page https://ardupilot.org/copter/docs/radio-failsafe.html