Radio failsafe and then RTL doesnt work

Today while flying with quadcopter Radio Failsafe triggered and drone started to fly home position. and at this moment i also activated RTL but when Radio Failsafe cleared it went back to last position where it was started to RTL. RTL didnt work. Then i switched to Loiter mode and i brought back to quad by myself. is there any opinion about this situation? This is normal? My FC is Matek H7 Slim, Gps Beitian Bn 880.

can you post a log from the flight.

i dont have any log ile but i have video if it helps.
i am newby about this log topic.

The log should be on the SD card of your flight controller. The latest .bin file. Without a log all we can do is guess.

Ardupilot only changes flight modes when you trigger the change. So if you flipped the switch on your radio to change flight modes while the radio was disconnected it may not have registered the mode change when it recovered. Possibly once you cycled to loiter, you may have been able to cycle back to RTL again and it would have worked.

I understand. It is possible it didnt work during failsafe. I dont have sdcard on my flight controller and i should buy one probably. Other times rtl always works. Before i fly away i always check if rtl works and then i fly away.

You should buy one definitely as the cause of your issue, if there really is an issue, likely will not be solved without it.

Also FENCE_ENABLE,1 means that you cant arm and take off before there’s a reliable GPS 3D fix, so you’d know RTL would have a Home to come back to. You do have to wait a while sometimes, but you get used to it and it means more certainty.
Some say to start in Loiter mode, which also requires a GPS 3D fix, but setting FENCE_ENABLE,1 takes the human error factor out of the equation.
This way you’d only need to check you failsafe actions once during test and tuning for verification instead of every flight.