Servers by jDrones

Radio connection rate is only 10% after using EKF3

Hello everyone, I am testing the GNSS dual antenna sideways on the ardurover to replace the magnetic compass. I set the parameters EKF_TYPE = 3, EKF2_ENABLE = 0, EKF3_ENABLE = 1, EKF3_MAG_CAL = 5, run EKF3, but my station loses packets after running The rate is too much, the connection quality is only 10%, I changed to EKF2 and everything is normal, the same hardware. . . Why is this? Below are the log files of ekf2 and ekf3. Thank you. I am running ardupilot under linuxRT on am335x processors.

Sadly, I’m unable to get those logs. It certainly doesn’t help that I can’t read Chinese - but when I click on likely-looking buttons it seems to be inviting me to install something or other rather than giving me the log…

Is there some other service you can use to supply them?

Peter

… also, does it do that when you don’t set the MAG parameter?

I actually banned the compass completely. . . I will not disable the compass test tomorrow, of course I will upload a log file tomorrow, thank you

This is the log file link:https://send.firefox.com/download/b6839da5a624319c/#73nrDDt7_Przoia25Y3Zcg

Servers by jDrones