Radio Calibration Throttle & Yaw Reversed

Had a couple of flights with my Hquad today with no problems. Decided to update the firmware with 3.3 rc5 from 3.2.1 via Mission Planner, no problems encountered. Decided to recalibrate the radio. Mission Planner identifies my throttle as Yaw and vice versa . Went back to firmware 3.2.1 and again recalibrated the radio, yaw and throttle still reversed. Checked Advanced Params - Pitch = channel 2, Throttle = channel 3.

Tied down my Hquad and armed. The props spun up normally on the throttle stick.

Not sure whether I’m doing something incorrect or if there is a problem with Mission Planner.
Can someone please point me in the right direction if I’ve missed something.

Mission Planner build 1.1.5644.40806

In the post above I wrote Channel 2 = Pitch. I meant Channel 4 = Yaw. Sorry for any confusion.

are you sure your rcmap params are the same? I do know that rcmap has been refactored in copter recently, so it may be that but cant be sure.

My friend showed me this bug. As we found out it’s all about calibration marks display only. All calibration values were recorded correctly.

Thanks Meee1 and Sagaris for your replies.
I will check the rcmap params (Once I figure out what they are). After my initial post I tried APM Planner and it’s showing throttle as throttle.

Hey Jon,

I’m actually having the same exact problem as you right now, but all I did was update Mission Planner to 1.3.29. Prior to the update, I believe I was running 1.3.19 (my original install was in December 2014 I think)? My copter itself is still running v3.2 firmware. All I did was update Mission Planner and this issue presented itself.

Things I’ve tried so far:
Radio calibration (twice, no luck)
Checked rcmap values (all looked good, throttle is CH3, Yaw displayed as CH4 like it should)
Powered everything down and back up (about 3 times)
Verified my radio was still sending throttle on CH3 and Yaw on CH4

I’m at a complete loss. I wonder if there’s a way to downgrade Mission Planner? I’m can’t fly until I get this fixed. Let me know if you found a fix for yours?


Try here

Getting the same thing. Tried three different operating multi’s with Pixhawks. Tried different receivers… Tried beta MP. No difference. RC mapping is correct. One thing really odd, not only is the throttle and yaw swapped, but roll is completely missing lol! Same for you guys? No effect on the actual multirotor. Just don’t think I’d do a calibration until it’s figured out. That’s lame though, I’ve got two X8’s and new hex really to go : (

Correction, the roll display bar is there, just hidden by the top menu. Tried it on my workstation with MP 1.3.29 and it works fine. It’s only 1.3.29 the calibration gets messed up.

Thanks for that. It’s only present in 1.3.29. 1.3.38 does the radio calibration just fine. Uninstalled 1.3.29 on my laptop and installed 1.3.28 and success. Surprised more haven’t run into this.

Try here
TCIII GM[/quote]

It’s fixed in today’s update.

Awesome! If that was a problem with DJI GCS… Well you know lol!

Thanks theo3000 for the update

Confirmed, fixed in 1.3.30.

Thank you!