Radio Calibration error

Just received my new PX4 and have a problem doing “Radio Calibration”. The calibration screen does not show ANY green from the start. After finishing with the failed calibration, I get a message INPUT 1 FAILED CANCELED. Have tried three different receivers. I figure it is ME and not the device.

Need some help on this one.

Can you describe some of your setup in more detail?

The terminology is confusing, so I want to make sure we understand what you’re posting. You probably bought a new PixHawk (not a PX4, that’s the name of non-ArduPilot software) and it might be a PixHawk 2, or it might be a PixHawk. (often called PixHawk 1, to prevent confusion.) Or you might actually have bought something else? (PixRacer, PixHack, APM 2.x, etc…)

Can you find the name (or post a picture) of your autopilot? (the thing you called “a PX4”)
What kind of TX/RX are you using?
How are you connecting your RX to your PixHawk?
Are you using Mission Planner as your GCS software?

With no label, I cannot specify the exact name on this device. I assumed that to use the source of this purchase is a no-no.

I am using a Spektrum DX7 transmitter
I am connecting directly from the receiver to the AUX OUT of the device in question.
Receiver bind is complete.
I am using Mission Planner, but also tried APM Planner 2

Couldn’t find a way to send photo.

The seventh icon along when you post is a bar with an arrow above it.You can upload photos thorugh that if they are not too large.

Rats…I was looking for a way to send a photo on the forum, but forgot I could via the email. Here’s the device in question.

Found your problem: Aux out is not the correct place to connect your RX. The receiver needs to be connected to RC IN via a PPM converter.

Thanks for the response, but I thought I read it is compatible with Spektrum DSM. So…what is this formally called and what software should I download? I think I’ll revive my APM 2.6!

Thanks Hunt0r

Oh, I didn’t realize you had a Spektrum/DSM receiver. Maybe this documentation page will help?

Got it working. In my box of “stuff”, I found a DSM receiver that has a PPM output…that did the trick. I appreciate you help

1 Like