Servers by jDrones

"Radar"/DISTANCE_SENSOR screen


(Fabrício Silva) #1

On Help with object avoidance, ppoirier reports that MP can show automatically a “radar” screen.

I’m sending DISTANCE_SENSOR messages (more info here: Help with object avoidance) to ArduCopter, but MP does not show this screen.

What are the requirements for MP to show this screen?

On QGroundControl Mavlink Inspector widget, I can see DISTANCE_SENSOR messages coming. In MP, is there a similar way for debugging mavlink mesages? I really do prefer MP.


(ppoirier) #2

Hello, its me again :slight_smile:

Mission Planner need to connect to a vehicle that has proximity enabled in order to show the RADAR Screen.
This vehicle can be the simulator -SITL- with the correct parameters being set.


(Fabrício Silva) #3

ppoirier, thanks again for your time. :slight_smile:

Could you please, be more specific on the requirements?

I tried many scenarios but I still can’t get the screen shown.

I tried:

  • Connecting MP through UDP (via cmavnode and mavproxy), while sending messages also via UDP.
  • Connecting MP through USB, while sending messages through serial (TELEM2).
  • Arming, changing flight modes.
  • Sending heartbeat messages along distance messages.
  • Sending rangefinder and distance_sensor messages.
  • Using different sysId and compId.

QGroundControl (connected via USB) shows distance_sensor messages being received. If I disconnect QGroundControl and connect MP (via the same USB) it does not show the screen.

I have set AVOID_ENABLE=2 and PRX_TYPE=2 on ArduCopter (3.4.6). Any other parameter needs to be set?

I posted this message with “Mission Planner” tag in the hope that a MP developer could give me a more specific answer.

I feel that I’m so close to getting this done, but it has been so frustrating…


(ppoirier) #4

Here is the test setup, I suggest you prepare

LIDAR - I2C - RPI (Running your Proximity Message) - SERIAL - USB - PC (RUNNING SITL) - UDP - PC (Mission Planner)

You need to start SITL with a connection to your serial-USB (FTDI) converter see here for detail:
http://ardupilot.org/dev/docs/using-sitl-for-ardupilot-testing.html#using-real-serial-devices

and then you instruct SITL to --out udp:mission.planner.pc.adress:14550

make this all work, and let me know


(Fabrício Silva) #5

I managed to get the “radar” screen displayed.

The problem was ArduCopter 3.4.6. When I switched to 3.5-rc11, a window simply poped-up.

I don’t recall now why I thought 3.4 was enough. Maybe a mistake.

Although MP displays the screen, its bahavior is quite weird. Radar window is initially displayed with a white background. Then, it switches to dark grey. Then multiple windows are displayed, with the same content. After about 1 minute, a error window is displayed, while all radar windows display a red “X” on white background. The error message varies. If I disconnect and then reconnect to ArduCopter, lots of radar windows are displayed instantly, and I have to close them all.

I’m still trying to understand what is happening.


Help with object avoidance
(ppoirier) #6

Cool,
I should have read the 3.4… , really though that we mentioned the 3.5 before, probably on the other issue.
Anyway, I confirm that Mission Planner spits out a lot of radar screen, according to the number of sensors declared.
Is it a Bug or a feature ?!?!
Its up to you to open a PR if you consider that as a bug.


(Michael Oborne) #7

MP uses the DISTANCE_SENSOR message to display the screen.

@FabricioSilva there is no gui method of the mavlink inspector. but you can turn on console logging, and analyse the logs afterwards.

I do plan on adding something similar to the mavlink inspector however.


(Tomasz) #8

Hi
I try to build a avoidance system using VL53L0X. I find VL53L0X version with max 10 m range at http://www.robotshop.com/eu/en/vl53l0x-time-of-flight-distance-sensor---50-to-1200mm.html.
Now I using VL53L0X with 2 m range to test it. In ardupilot full parameters list I find RNGFND parameters value 16 is for VL53L0X. But If I connect my pixhawk to MP there are only parameters start 0 to 15…
I use arducopter 3.5and MP 1.3.49 build 1.1.6410.20232.
And next question
Witch parameter needs to be change ?
I try to set RNGFND_TYPE to 16, AVOID_ENABLE=2, and PRX_TYPE=2 but I get only BAD LIDAR HEALTH message in MP.
Regards
Tomek


(ppoirier) #9

You should see the distance values when you set the rangefinder correctly is it the case?

Btw the VL53L0 has a range of 1,2 meter


(Tomasz) #10

I set RNGFND_MIN_CM to 2 cm and RNGFND_MAX_CM to 200 cm.
I will try to decrease RNGFND_MAX_CM to 120 cm
Regards


(Fabrício Silva) #11

Thank you, @Michael_Oborne!

It’s a pleasure to get a reply from you. I’ve been following your work on MP for a while. Congratulations for it!

As I said before, after migrating to Copter 3.5, the radar screen appeared. Debugging is not necessary anymore, but thanks for the tip, anyway. I noted that Ardupilot wiki on “Object Avoidance” was updated on this matter.

I’be be grateful if you could explain these behavior issues:

  • MP shows multiple radar windows, supposedly one for each orientation. Why not just one?
  • Some radar windows have white background and some gray background.
  • When disconnecting MP from Copter, radar windows sometimes appear showing outdated data. Could it be a buffer issue?
  • When opening MP, radar windows sometimes appear showing outdated data. Could it be a buffer issue?
  • I get frequent software exceptions, all related to the radar screen. I sent some bug reports about this (directly from MP).

Suggestions for MP:

  • Migrate distance UI from radar screen to HUD. It could be just numbers (withouts red archs).
  • Display upward and downward distances.

(Shizzavip) #12

ppoirier… Wondering if you are at a point with the poc that you would be willing to post the code… I have been working on this for a bit and I can get certain aspects to work using the VL53L0X just not like your examples and videos… I think its just a matter of my lack of understanding so it would be nice to have something to compare to… Thank you in advance for any help you can provide.


(ppoirier) #13

The code is on the thread you are pointing to at beginning of this discussion

I have not played with it since , might get back to if the new BENEWAKE TF MINI , 20 Meter works ok


(Shizzavip) #14

I have reviewed that and any other similar items I could find but I’m still having some difficulties with it. Would just be nice to have something to compare to so I could see what I’m doing incorrect. The problem with a lot of this stuff is it is changing so examples and other folks work no longer work as they once did. Makes things a bit frustrating, I have a lightware rangefinder that works perfect but was not cheap so I was really looking forward to this cheaper solution for the in between.