R22 Heli SITL Waypoint Navigation Problem

Hello dear forum members,

Using Ardupilot software (I have tried both 4.3 and 4.5) I am trying to set up R22, Raptor and Jetranger helicopters using X-Plane 10 simulation on QGroundControl software.
In all 3 the attitude and altitude controllers work fine. But in navigation modes like Guided, loiter or Auto the simulation shows very strange behavior.
I have been trying to solve this strange behavior for a long time but without success. During this time the main source of the problem is as follows:

  • The helicopter cannot turn its face to the waypointe, especially when it gets close, it even spins (even if I change the yaw behavior setting, it doesn’t work).
  • Even if I manually control the yaw of the helicopter, it cannot stop itself after passing by the waypoint.
  • When I give forward input when the helicopter is in Loiter mode, sometimes it takes more than 30 seconds to recover and go to full hover, sometimes it flies forward without recovering at all.
  • I tried the navigation modes related to these issues first without tune and then with tune (I could not, but I updated the parameters according to that vehicle).

  • The most important point of the issue is that I can easily do tests using MP on windows. But I had to move my work to Linux (Ubuntu) and I no longer use windows actively. I will not be able to use it during the flight.

I am attaching the log graphs that caught my attention below. I can add any additional graph you want.

Is there anyone who can help?

Log screenshots are of little use for pretty much all issues.

I have added the log file. Thank you for your support and feedback. I hope we can resolve this issue.