Questions on test functions on CLI (not working?)


I tried to do the motors test, but nothing happens, i.e., none of the motors spins. Which parameter(s) do I have to check in order that this test is working? I followed the guideline (Checking motors directions with CLI, … nd-motors/)

I have a pixhawk (2.4) with DJI F450 Kit and 3DR power module.

Besides, what is the “motorsync” test for?

Thanks for your help!

Hiya Seany :
I know what I am saying is not in the right order…but here are a few “ tests “ I did with similar problem
1.-Have you tried each individual motor – with its ESC – directly connecting to the Receiver – Port 3 and bypassing the APM - PIX??? other words as if you where to fly that motor in an airplane – i.e RX –port3 to ESC—esc to motor ?? because if the motor doesn’t run in that mode something is wrong with the basic set up and therefore it would not run anywhere else.
2.-Are you able to do the ESC calibration at all ?? ¿??
3.- And if all above is working , then in the Mission Planner CLI …can you “CONNECT” from there and get into the SETUP command ???
I hope something explained above throws some light !!!

Hi Ramon,

thanks for your suggestions! Probably, my formulation was a bit misleading. The motors actually work, i.e., after arming the device I can regulate the speed of the motors using my RC. But that is why I am a bit confused why the motors test in the current version of MP does not work.

To get back to your suggestions, I already wanted to directly connect the motors to the receiver, but unfortunately I would have to use an adapter as the plugs do not fit (there is an additional plastic node at the cable to the ESC that does not fit my receiver). However, the motors are not the problem, see above.
Besides I cannot do an ESC calibration, as the ESCs are form DJI (F450 kit) -> no calibration possible nor mandatory…

In the meantime I checked the turning direction by other means, but the question still remains why the motors test is not working despite the fact that I can successfully throttle them by my RC.


I’ve had the same problems with tests not working in CLI. Connected via USB of course.
Specifically “motors” The hex flies well and I’m running the latest release versions of AC and MP.


Hiya Seany :
I see…the way I read the post was that the motors had worked already in the past“ in a APM “ environment . The only other thing I can suggest is that you get at least one “normal” ESC…I mean with standard connections…non DJI ?? …I real “ cheapo “ ESC…is only to do tests even a 10/15 amps will do. Then connected up , as the instructions provided in the link you mentioned , and see if that motor works in the APM environment. The TEST MOTOR command will still work by making that motor spin for 1 second at low revs, it does not matter about the other ESC-or motors positions , they might still not work …but you might have that “standard esc “ motor spinning for a moment and that sign is what you looking for.
Kind regards.

ok, I’ll try this as soon as I manage to get another ESC.

Thanks for the suggestions and thanks for the info that I am not the only one having this problem!


you are pressing the arming switch?

Hiya meee1 :
I used the testmotors command in the Mission Planner CLI enviroment – without any radio switches -just the USB cable connected directly between the PC and the APM .

Seany…. ¿¿ you are connecting the USB cable to the APM …???..or are you using the radio ??, because the testmotors command is transmitted to the APM via the USB cable ….well …that is how I tested that command …and it worked , but before I had to calibrate my ESC´s , and that needs the radio to know the min. and max of the throttle stick ….this worked for me prior to use the " testmotors " command via the USB.

@mee1: yes, I pressed the arming switch.

@Ramon: yes, I connected via USB cable.

But I solved the problem now. Seems like the motors did not spin during the test due to too low values of “minimum throttle” (THR_MIN). I raised the value and now the motor test works (as well as the motor sync test)! :slight_smile:

Thanks for all your suggestions!