Question about PX4 GPS Direction showing in mission Planner

Hello I would be grateful of some insight, This is my first test build of a pixhawk quadcopter,
Went thru each each of the steps in the wizard in mission planner and seemed all ok

A little bit about my hardware and software.
Pixhawk Clone on a quad frame APM:Copter V3.4.6
DJI esc’s and 2212 Motors
mission planner 1.3.46
PX4 Power module
433mhz telem modules

Snipped from mission planner message window,

EKF2 IMU1 is using GPS
EKF2 IMU0 is using GPS
u-blox 0 HW: 00080000 SW: 2.01 (75331)
EKF2 IMU0 Origin Set
EKF2 IMU1 Origin Set
GPS: u-blox 1 saving config
PX4v2 003C0044 31345103 35303739
Frame: QUAD
PX4: de6b667d NuttX: 8c965992
APM:Copter V3.4.6 (e707341b)

My problem is that mission planner is showing the compass pointing north and gps direction is south?
with the quad frame pointing north and rotating clockwise the compass / gps direction moves clockwise
but the gps direction all ways settles showing 90 degree’s out, ie compass pointing south gps pointing north
Is this how its supposed to be.

Any suggestions would be helpful.

Hi Paul,

I would recommend you read the wiki:

Probably you haven’t mounted the GPS correctly or your compass has the wrong orientation set.

Thank you I will take a look at the wiki pages

Double check compass orientation, it sounds like it needs to rotate 180 degrees in yaw. But also consider that the compass may be improperly marked. I had one from an unnamed seller that was incorrect, and I had to use a different compass orientation than expected. I found these instructions helpful for determining the proper compass orientation in that case:

Basically, you tilt the copter and watch X and Y components of the compass (available in the telemetry in Mission Planner). Depending on how they change with pitch and roll, you can determine the orientation of the compass. For me (northern hemisphere), a right roll results in increasing Y, and pitch down results in increasing X.

Thank you for your reply, I tried various combinations of orientations, I am sure that the compass’s are working as expected, copter pointing north and compass showing north etc!! but the gps direction in any orientations allways seems close to being 180 degree out, like copter pointing north and compass points north but gps direction showing south…

mission planner screen shot compass pointing north and gps points south

mission planner screen shot compass pointing south and gps points north

I have tried various orientation’s but still no joy.
any idea’s would be grateful

This looks fine. If the red line matches the orientation of the copter you’re fine. The GPS direction at rest will be random and doesn’t really matter. It will converge to the direction of flight once it gets moving.