Question about disabling RTL in Mission Mode

I’m trying to get my IRIS+ to continue the mission even if I shut off the controller and telemetry radio. i.e. the goal is to have it be able to do missions that are out of line-of-sight.

I tested that shutting off the radio halfway through a mission would cause it to RTL and it worked correctly.

I then set FS_GCS_ENABLE to 2 which is “Enabled Continue with Mission in Auto Mode”.

Then I did the same test and shut off the radio halfway through the same mission (When I say radio I mean the FS-TH9X controller). Telemetry was still connected. The result was the usual RTL. I was expecting it to continue with mission.

I’ve looked at the log and I can see where the radio loses connection and it goes into RTL mode. Not sure attaching the log would help, what I’m interested in is what settings are required for the drone to continue mission out of reception of either radio.


Can you post the log? Trust me. It will help. Thanks

I tried to attach the log and got file too big error. The file is 8.8 megs and it looks like the limit is 5 megs. Any suggestions on how to trim the file without losing integrity?


Zip the file, it should compress near 50% or stick it on google drive or drop box and post a shared link.

Just a followup. I resolved this myself after looking at one of the flight logs. Realized looking at the CMD’s that the geofence kicked in which is what brought it back. I was sure I’d disabled that. After disabling that and setting FS_GCS_ENABLE to be completely disabled (0 I think) I’m not flying completely autonomously even when it loses the telemetry (900 mhz) and controller (2.4 ghz) radios.