Servers by jDrones

Quadranger Pixhawk 2.1 EKF compass issue

(DCLLC) #1

I have a quad ranger that has one of the new Pixhawk 2.1 in it, the only difference between it and our quadranger that has original pixhawk in it is the location of the here gps module. on the one with the piwhawk 2.1 it is mounted on top of the black motor mount, and on the original pixhawk it is mounted on the tail boom, see photos to see where its mounted. the quadranger with the pixhawk 2.1 takes off great once in hover and you give it a yaw motion it blows the compass ekf through the roof, and never settles back down after that. On our quadranger that has the original pixhawk in it we get never blow the ekf out on anything unless its a crazy windy day and in that case we actually shouldn’t be flying. here is an image where each GPS is mounted, I am working on trying to get some data flash logs but having a tough time due fire season here in Montana its been a brutal long haul and im ready for it to be over.
Has anyone else had any ekf issues with their new pixhawk 2.1, took us forever to get the compasses even to calibrate!!! seems it is much more sensitive to ekf than the original pixhawk. the one thing i have not tried is to mount here gps where the original pixhawk gps is mounted but I’ve gotta make a new cable since the one that came is not near long enough!!

(James Pattison) #2

The compass is best placed as far from high current components and cables as possible so it’s very possible that you are seeing significant interference on the Here, located above the motor. A log would provide some clarity on that.
Have you tried moving it? Even having it forward or inside with the ph2 would give you an idea as to whether emi is your problem.

(DCLLC) #3

Here is a DF of a hover test with the EKF compass blown way out once you yaw any direction. here is a link to the small DF file. I have made a longer cable and moved the GPS to the same spot as it was on the original pixhawk, going to try a hover test soon and see if it has resolved the issue. there also maybe some settings in there that are off a bit as well was just trying to get all compasses to line up properly.
Thanks a million for taking a look at it.

All the best,

Matt C.
QR2 EKF issue

(Amilcar Lucas) #4

Looks like this bug: