Quadplane spinning on takeoff

For the last couple of months I’ve been trying to track down the cause of a quad plane running 3.7.1 that spins (yaws) on takeoff. While this type of thing typically is related to hardware I’ve tried everything I can think of and really think that it’s not related to the build. Because I’m more familiar with Arducopter I started out flying it with the copter firmware and it actually takes off properly. So I’m at a real loss as to why I can’t get it to take off vertically with Arduplane.

The airframe is a HobbyKing Darkwing - https://hobbyking.com/en_us/darkwing-fpv-drone-1727mm-composite-arf.html

The latest log from a takeoff attempt and the param file are here: https://www.dropbox.com/sh/62671xaajxg3avw/AAAj_EDfOPTBdmHSLeryVaELa?dl=0

Photos of the build are here: https://flic.kr/s/aHskzLBC9x

At a guess I’d say I just have a parameter set wrong. It almost feels like I have no yaw control at all from the Tx.


Try changing Q_A_RAT_YAW_P value from 0.18 to 0.4 and the Q_A_RAT_YAW_P value from 27000 to 100000.

Other param changes that may help are:

  • Q_A_RAT_YAW_D,0
  • Q_A_RAT_YAW_I,0.02
  • Q_A_RAT_YAW_IMAX,0.3
  • Q_A_RAT_YAW_P,0.4
  • Q_A_SLEW_YAW,18000

Thanks Greg. I just got back from testing with those parameters and it didn’t make a difference. The plane still spins on takeoff. However, just to make sure I wasn’t going crazy I decided to load up Arducopter once again and take it for a spin. It worked fine although with the wings on, there was a large oscillation on the roll axis.

When I was loading copter I noticed what might be the problem. I’ve been running copter as an X frame even though the frame is a H configuration. I noticed today that the two are not interchangeable and that a H config requires different motor direction and ordering. If it’s the same in ArduPlane quad config then that’s where I’ve gone wrong.

I’ve been selecting a H frame in QuadPlane but the frame is wired as an X config. I don’t know if Arduplane requires the two to be different like Arducopter does but I would assume that they share code so maybe that’s been the issue all along.

Does the motor test in Mission Planner catch the difference between a H and X config? I’ve been running it whenever I change firmware and it’s always confirmed an X config even though I have a H config selected in Arduplane.

I’ve just come back from a second trip to the field today to test. Sure enough it was the frame type being set to H in
Ardudpilot causing the issue. I built the frame wired up as an X frame as I had no idea that the two different frame types required the motors to be wired in different directions. So mystery solved.

Nice catch! I’m glad you found it.

what is the approx dimension of ur quad copter frame part?