Quadplane Pitch Control in QHover

Would appreciate some help. Quadplane setup on a V Tail. In QHOVER mode all the control surfaces work the correct way and the gyro compensation when tilting the plane on all axis is correct. when taking off in QHOVER the pitch control is inverted. Pushing the stick forward will reverse the plane and pulling the pitch stick back will make the plane go forward. Any idea how to fix this problem?

Are you sure that your channel 2 RC input is not backwards? http://ardupilot.org/plane/docs/common-radio-control-calibration.html

I am rather sure because if I reverse that and reverse the VTail servos then the Gyro compensation in FBWA or any other mode works incorrectly (reversed) on the flying surfaces.

Switch your L&R V-tail servos. Then everything should match up.

Thank you, it make sense! Will try tomorrow!

Good Morning Nathan,

Not sure whether I am missing something? I have swopped left and right VTail around and must then reverse the servos to give the correct direction when pulling and pushing the elevator stick. (I have done this in software and physically and both deliver the same result. All correct but QHover pitch still inverted. When you look at the instructions as you attached it says that the pitch channel on the radion must be inverted, if you do not do that then the gyro compensation on the elevator is inverted. Any more ideas? I am rather desperate to find a solution.
Best Regards,

Just so that I understand properly,

  1. You set the servos (SERVO_x) as reversed (or not)
  2. You do a FBWA check to see if the stabilization is in the right direction
  3. You set your transmitter channel (RC_2) as reversed (or not)
  4. You check that your transmitter stick goes is in the right direction and gives proper control surface deflection
  5. You fly in QHover and the pitch is backwards
  6. If QHover pitch is backwards, switch Left and Right VTail and repeat all steps

Is my understanding correct?

Hi Nathan,

Yes your understanding is correct. I have solved the problem. I completely reloaded the firmware and re did the setup from the beginning and not from the file. It is now correct and not sure why? Thank you for your help and advice.