Quadplane only displays Flight Modes for Copter

It’s been a little while since setting up a Tailsitter, but it was straight forward and I recall setting the flight modes without an issue from the pull down menus.

Now when I try all I get is the flight modes for Copter.
There are no Plane flight modes listed.

Is anyone else experiencing this.

I uninstalled MP and installed the latest, then upgraded to the latest Beta.
No change.

Does anyone have any suggestions on what might have changed or whether I am holding my tongue wrong or something.

you have definitely flashed plane not copter?

Yes, twice.
It was my thought too.
Maybe the FW flash was bad or something.
All the QPlane parameters are there and I am having to set parameters up in the Parameters list not the setup windows.
It worked previously in earlier versions but its been quite a few months since I played with plane.
And when connected it says “plane” in the window title.

thought I better ask, not sure what to else suggest, maybe flash to rover or copter and back to plane again

Will try that today.
:grin: I should have stated the obvious in the first post, no worries.
I often have to ask the same obvious questions when trying to help people.

It’s just such a strange occurrence.
Failing that I might try installing an older version of MP and see if things change.

Although I had installed copter previously, and then over wrote with Plane, this time I tried Rover and then over wrote with Plane.

It now works and is seen by MP as a Plane even with Q modes enabled.

1 Like