Servers by jDrones

Quadplane Octaquad Servo buzzing


(Wesley) #1

Hi,

We’re building a Quadplane, and using the Octaquad (8 rotor) setup - Q_FRAME_CLASS = 3. We wanted to plug all the ESC’s and servo’s into the Pixhawk (get’s pretty tight in there).

I think we found an issue where the analogue servos (Ele, Ail, Rud) start buzzing and the servos heat up as soon as the arming button is pressed if Q_FRAME_CLASS = 3. There is still a faint buzzing sound audible if we switch to digital servos. If we change Q_FRAME_CLASS to 0 (quad setup) the buzzing stops. We also tried earlier versions of Arduplane, and the problem is present in those versions.

We moved all the PWM outputs (servos and ESC’s) to an SBUS Splitter, and the problem does not present itself there.

Let me know what logs (if any you may require).


(Josh S) #2

I have this exact problem, any chance of getting some feedback?


(tridge) #3

Hi @wjversfeld and @gotmynina, sorry for not seeing this topic earlier.
Can you tell me what motor ordering you have? My guess is that somehow you’ve ended up with the fixed wing controls running with a high PWM refresh rate, too high for servos.
Also tell me what exact version of plane you are running and send me any log file so I can extract your parameters.
I’ll then check with a logic analyser to ensure the PWM rate is right for the fixed wing control services.
Cheers, Tridge


(Josh S) #4

I’m using 3.8.0 beta 4, this issue is resolved for me if I change q_frame_class to quad instead of octoquad. Ill have to get a log from the plane. Im started with default mappings and have only changed ails and throttle to see if this was limited to a certain outputs, it is not.

I don’t have a good log, but this occurred with default parameters on both pixhawk and pixhawk2.1. I did have ails and flaps mapped to aux 5 and 6, because of design issue with main 1 on pixhawk2. 1, but this occurs when they are mapped to main outputs as well


(tridge) #5

ok, I’ll test with defaults.
Is it a pixhawk1 ?


(tridge) #6

I’ve reproduced the problem, thank you very much for reporting this! It is an important bug


(Josh S) #7

Thank you, I had the issue with pixhawk 1 and 2.1

-Joshua Schmitt


(tridge) #8

I’ve pushed a fix here, pending review:
https://github.com/ArduPilot/ardupilot/pull/6011
and a prebuilt firmware for you to try here:
http://uav.tridgell.net/tmp/plane-fmuv2-alt-rate-fix.px4
again, thanks for reporting this, its an important fix! Servos could have burnt out in flight causing a crash


(Josh S) #9

here a link to my second hover test. it wouldn’t fit here. it was very sluggish and ended up tipping into grounder due to a breeze, but I should have gotten higher off the ground as well.


(Alexander Perez) #10

Hi Tridge. Does ArduPlane 3.7.1 have this fix incorporated already? I as well am building an OctaQuad Plane and seems it’s frying my aileron servos. I’m using 3.7.1. Or is it incorporated in the new 3.8 beta release?


(Alexander Perez) #11

Just an update for anyone who has been experiencing this issue…I’ve gone ahead and installed the ArduPlane 3.8beta. Seems to be working now as an OctaQuad Plane without any buzzing or heating of the servos. This is working for both the Pixhawk 1 as well as Pixhawk 2.1.


(Chris Maier) #13

I too am working on an OctaQuad Plane and had this issue. After switching to the beta 3.8 firmware the problem went away, however I had a motor mapping issue as well. Did you experience anything like this?

http://discuss.ardupilot.org/t/octaplane-motor-mapping-issues/18913


(Alexander Perez) #14

Chris,

In regards to motor mapping, I’ve realized (from using 3.7 quad setup) that the motor test sequence does not follow the multi-rotor mapping/direction. I haven’t tried it to be honest in 3.8 given my past experience. I basically test the direction and mapping by visual inspection while armed. I then ensure the rotors are spinning correctly as per mapping. It’s worked for me thus far.

Also, I’ve commented on your referenced post regarding your issue. I hope it helps.