Quadplane landing at lower altitude keeps failing

Hello pilots,

We have been testing our VTOL aircraft long distance flights with auto mission recently and found out the aircraft fails to approach and land on last stage. It started Qland instead of approaching to VTOL_LAND wp.

The thing is, take-off area is roughly 25m higher than landing area. We tried to use terrain altitude rather than relative but it still failed.

First flight seemed the aircraft tried to come down lower but Q_assist kicked in and the aircraft was flying up and down while loitering and suddenly it transitioned back to fixed wing mode. We had to manually bring the aircraft and land.

In the second flight, Q_assist was set to 20m which was lower than last wp, VTOL_LAND 30m. The aircraft still failed to make a final approach and proceeded to QLAND.

We tried several different mission setup in simulation but it sometimes made successful landing but sometimes failed just like in real flight. Our flight route is between island to mainland and take off area’s altitude is higher than landing area as mentioned above which seemed to be the reason of failing.

Current parameter might be slightly different from this parameter except Q_assist and terrain_follow but mostly same.

It will be greatly appreciated if you can share your experience and share some idea how to solve our problem. Thank you.

Mission No. 19 LOITER_TO_ALT should have an Alt parameter larger than Q_ASSIST_ALT, for example 35m.

1 Like

Thanks for your information.

Yes, we also confirmed it with simulation.

Unfortunately, the aircraft is under deep water now. She failed to endure strong side wind and crashed into water soon after I posted this TOPIC. :frowning:

Have a good weekend!

1 Like

Faced the same problem on Plane 4.3.8 during simulation flights. It looks like plane height controller gets wrong altitude setpoint causing full pitch down (if landing at lower alts then takeoff) just after VTOL_LAND mission command activates. However quad height controller looks like getting right setpoint (not sure 100% though) when quad kicks in after q_assist_alt reached. This is when using terrain frame for approach and vtol_land commands in the mission.
And in case vtol_land command has a relative frame set, height controllers work as expected. The only thing why this approach is still not usable is the early lift motors activation dew to q_assist_alt. This is because while altitude over terrain is ok, the altitude over home is negative in my case and it looks like q_assist algo depends on frame selected in current mission item.
So I see no way to land safely in a location which has a different altitude from home point, and it needs home to be set at the point where the landing is planned before actual landing.

1 Like

Thanks for your input.

Yes, we also concluded, not 100% confirmed tho, home point needs to be modified before apprach flight or at least before aircraft’s altitude goes down below assist_alt altitude. When we tested with our multicopter on a long distance flight with altitude of two points different, after changing home point copter went down accordingly referring to the altitude of new home point as it hit a WP. Copter DIDN’T begin to change its altitude immediately as soon as we changed altitude.

I also agree that we have to set mission’s WPs as terrain not relative. But, it was in relative setup when copter changed its altitude during the flight mentioned above. Absolute altitude might be a solution for it but we need a test to confirm it.

1 Like