Servers by jDrones

Quadplane forward flight ESC issue

Hey guys, we are working on getting our quad plane up in the air. We have followed all that is outlined here http://ardupilot.org/plane/docs/quadplane-support.html (Super helpful btw) however we have had a few issues.

The ESCs we are using are:

  • Quad: Wraith32 - 32bit 35A BLHeli_32 ESC DSHOT1200
  • Forward Flight: Wraith32 Plus - 32bit 50A BLHeli_32 ESC DSHOT1200

The first was that we were unable to spin up the quad motors. We solved this by setting Q_M
Q_M_PWM_TYPE to 2 from 0 (OneShot 125).

The issue we are facing at the moment is that we are unable to get the forward flight motor to spin (Even in manual mode). We have confirmed that the motor and ESC works (Used a servo tester)

We have also calibrated the ESCs according the Quadplane guide. However we still have had no luck with the forward flight motor.

I have uploaded the logs from the attempts we made. Just wondering if we are missing something obvious?

Appreciate any insight, thanks!

EDIT: Couldn’t upload the logs to this post, please find them here: https://drive.google.com/open?id=0B87wV94OJ5sfQkZfWmxHOWRMTjg

What flight board type is this on? Looks like it might be a PH2.1 cube?
The logs show you are getting PWM going out on your fwd motor, so it should be working. Some ESCs will only internally arm if the PWM they get drops below minimum at startup. I notice you have SERVO3_MIN=1100 and SERVO3_TRIM=1100. Have you tried lowering those to 1000?

2 Likes

Hey Tridge,

Thank you so much, we are using PH2.1 Cube. Changing SERVO3_TRIM and SERVO3_MIN to 900 worked - you were 100% correct!

Thank you again!

1 Like

glad to hear it!
Cheers, Tridge

This just helped me out. I was going to create a new topic but decided to search to see if anyone shared on same issue. Thank you so much, Tridge!

Servers by jDrones