Servers by jDrones

QuadPlane Conversion of Hobby King Bix3 Trainer

(Greg Covey) #21

Thanks guys. Also thanks for the added information, Jeff. My next test will capture several transitions on video to see if we want any settings changes. I have a second 4s 2.8AH battery pack coming. Along with the second pack, and now knowing that my initial flight used less than half charge, I can fly more comfortably. I also think I will close up the front openings of the 15mm square carbon tubes. Changing from the stock 3s Lipo to a 4s for QuadPlane seems to have negated the effect of any extra drag from the conversion.

(Greg Covey) #22

I made some end caps for the 15mm carbon tubes from a small piece of flooring foam which is very light and has high compression. Alternatively, I also found some nice 15mm end caps on eBay here. Lastly, I started cutting off the excess screw length and sand the sharp edges with a Dremel tool.

(Greg Covey) #23

My second flight on the Bix3 QuadPlane turned into a test of its power and stability in 15mph winds. I was concerned that I didn’t have enough power to fly in these conditions as I normally would not fly a plane in a smaller area with 15mph winds. However, my initial experiments have made me a believer in the advantages of a QuadPlane as the Bix3 was stable from take-off to landing.

I’ll continue testing my Bix3 QuadPlane in various autonomous modes and Mission Planner flights while I start my next conversion of the larger Volantex Ranger EX. My Ranger EX will be used for mapping surveys so it will be a fun project!

(Iam) #24

Thanks for the video, it’s good to see other examples of successful Quadplanes. Q_STABILIZE and QHOVER require the wing to pitch down to fly forward, or in your example fight the wind. You should try QLoiter with Q_VFWD turned on. It’s really helpful to have the pusher motor fight the wind while the Qmotors are only used for vertical lift, and the wing can stay at a level angle of attack. I wish this were possible in Q_HOVER too. I wrote my wish in this GitHub issue

Another thing to try is Q_ASSIST. You can leave the plane in FBWA and bring it to a stop in midair, let the wind push it backward, then add throttle to fly out of it. You never need to switch modes to transition. In this video I’m in FBWA the whole time, and just cut the throttle.

It’s a lot of fun, and good to test on your Bixler so you get comfortable with all the Quadplane functionality before migrating to your Mapper.

(Greg Covey) #25

In my third flight test of the Bix3 QuadPlane, I tested Hybrid RTL. In Hybrid RTL, the QuadPlane starts its return to home as a fixed wing aircraft until it is close to the return point at which time it switches to a VTOL RTL. Before testing Hybrid RTL, the video shows several flawless transitions from QStabilize mode to FBWA and back.

My settings for Hybrid RTL were as follows:

  • Q_RTL_MODE = 1 (Hybrid)
  • ALT_HOLD_RTL = -1 (keep same altitude)
  • Q_RTL_ALT = 20 (meters)
  • RTL_RADIUS = 100 (meters)
  • WP_LOITER_RAD = 200 (meters)

Although the Hybrid RTL worked and brought my QuadPlane safely back to a landing, I had two issues.

Issue #1 was the “porpoising effect” that the plane had when initially returning to home. It reminded me of the Olympic swimmers in Rio doing a breast stroke.

Issue #2 (as denoted in the video) showed up when the QuadPlane was descending as a copter. About half way down to the ground, it lost the Loiter lock and started to drift like in QStabilize mode. I decided to compensate with my right stick forward to keep it from drifting while it landed by itself.

(Iam) #26

Watching your takeoff, it looks like your wing is at a slight negative AOA. It could just be the camera angle, but it appears the tail is higher than the nose. This would create a down force to oppose the Qmotors. I noticed that you aren’t using Q_VFWD, so during RTL, after transition, the plane must pitch the nose down even further to move forward. I can hear a fair bit of wind over the microphone, which would exacerbate the problem. I don’t think this could create your porpoising issue, but it’s worth giving Q_VFWD a try. A little more tilt on your Q_motors could help, but that’s probably too much work at this point. Consider it for your next build.

(Greg Covey) #27

Hi Iam,

I suspect that there are some bugs in the Hybrid VTOL. I have not seen any other examples outside SITL. If Q_VFWD_GAIN is zero, as in my setup, then the forward motor will not be used for position control in VTOL modes. I can gracefully fly around in QStabilize mode without any forward motor use as well as fly like a plane without any quad motor use. I would expect Hybrid VTOL to work properly without tweaking additional parameters as in my copters or FireFLY6.

Perhaps the ALT_HOLD_RTL of -1 to hold altitude was interfering with my Q_RTL_ALT setting of 20 meters. It also seemed like the porpoising issue started right after changing to RTL mode. Perhaps my RTL_RADIUS of 100 meters is much to long as my transitions are normally smooth and can probably be done in 20 meters.

Thanks for the suggestions…

(Greg Covey) #28

Hopefully, tomorrow I will test QRTL mode (flight mode 21 instead of 11) after first transitioning to QStabilize and from a distance that is relatively close to home. I will see if during the “Q_WP_SPEED speed towards the return point” if I get the same “porpoising effect” in Issue #1 above. Also, referring to the description of QRTL below, it appears that “Once the aircraft reaches an altitude of Q_LAND_FINAL_ALT then the descent rate will change to Q_LAND_SPEED for the final landing phase.” This is where I saw issue #2.

I am hesitant to try QLOITER mode because of several user warnings and the issue noted below in the [URL=“”]QuadPlane Flight modes[/URL] section. Let us know if you have had good or bad experiences with QLOITER mode.

“The landing detection logic in QLOITER mode is not as sophisticated as the landing detection logic in Copter”.

My settings for QRTL are as follows:

  • Q_WP_SPEED = 500
  • Q_WP_SPEED_DN = 150 (initial descent speed)
  • Q_LAND_FINAL_ALT = 6 (meters)
  • Q_LAND_SPEED = 50 (cm/s)

If you prefer to do return to launch as a VTOL aircraft (like a multirotor would do) then you can use the QRTL flight mode. That flight mode will transition to VTOL flight and then fly at the Q_WP_SPEED speed towards the return point, at an altitude of Q_RTL_ALT.

Once the return point is reached the aircraft will start a vertical descent towards the ground for landing. The initial descent rate is set by Q_WP_SPEED_DN. Once the aircraft reaches an altitude of Q_LAND_FINAL_ALT then the descent rate will change to Q_LAND_SPEED for the final landing phase.

In the final landing phase the aircraft will detect landing by looking for when the VTOL motor throttle drops below a minimum threshold for 5 seconds. When that happens the aircraft will disarm and the VTOL motors will stop.

(Greg Covey) #29

We tested QRTL mode and found the same two issues as described in the Hybrid RTL testing. When returning to home in quad mode, the plane exhibited the “porpoising effect” in Issue #1 and when the Q_LAND_FINAL_ALT of 6 meters was reached, Issue #2 (as denoted in the video) showed up which caused the plane to drift on its final descent.

My settings were as follows:
Q_WP_SPEED = 500
Q_WP_SPEED_DN = 150 (initial descent speed down)
Q_LAND_FINAL_ALT = 6 meters

In flight #5 below, I just had some fun with my Bix QuadPlane. I had just tried to fly the maiden flight of my Volantex Ranger EX using APM Plane v3.6.0 and it would not do a normal plane take off in the thick grass at the soccer field using the stock wheels. I have gotten so used to my copters, FireFLY6, and Bix3 QuadPlane being able to take off from anywhere so I will use an R/C flying field to initially test my Ranger EX before converting it to a QuadPlane mapper.

(Perth UAV - Sam) #30

Hi Greg
With the drifting issue #2 maybe try to see if it is Q_LAND_SPEED or Q_LAND_FINAL_ALT by changing the variables and test if it changes? I’d try the altitude one first, by setting it higher so you have time to recover, alternatively reduce your initial decent speed and make it lower etc. It would be strange if Q_LAND_SPEED changes the behavior, but maybe worth a test anyway.

As for the porpoising it looks like your PID loops are overshooting. Maybe try to increase LAND_THE_SLEW first and see if that helps. If not it might be TECS that is responsible. We haven’t experienced the purposing before, but are keenly awaiting 3.7 to released soon.

With qloiter we typically always have issues in light to high wind, mostly close to the ground where WIG creates substantial lift/turbulence. Typical behavior is that it momentarily dips one motor and hasn’t got enough time to recover before touching the ground.

Otherwise your Bixler looks great! (BTW maybe try a mini talon next with 6x4 props and Cobra motors for the H quad and a forward cruise at around 4A@17m/s)

(Greg Covey) #31

Hi Jeff,

Thanks for the suggestions. I will certainly try changing the parameters you outlined and report back. I was not familiar with the LAND_THR_SLEW parameter so I looked it up. My settings are currently the default below.


THR_SLEWRATE: Throttle slew rate - maximum percentage change in throttle per second. A setting of 10 means to not change the throttle by more than 10% of the full throttle range in one second. Range is 0-127 percent.

To clarify, after testing the Q_LAND_SPEED and Q_LAND_FINAL_ALT parameters, you want me to try increasing LAND_THR_SLEW to something over the current 100 used by THR_SLEWRATE?

Lastly, you mentioned that you don’t see issue #1 on your setups but how about issue #2? Has anyone else tested QRTL mode?


(Greg Covey) #32

Now that the crazy summer heat is gone, I hope to test the following parameter changes soon. After that, I’ll test my first autonomous mission. See separate thread.

Bix3 Parameter Changes
LAND_THR_SLEW = 120 (was 0 which means use THR_SLEWRATE)
Q_LAND_FINAL_ALT = 3 (was 6 meters)
Q_LAND_SPEED = 50 (same as before)
THR_SLEWRATE = 100 (same as before)

(Greg Covey) #33

Here’s a few images of the Bix3 hovering and flying.

(Expntly) #34

Very nice Greg!

What are the 5 motors / props you use? What about the battery, especially the C ratings?

Any idea what is the AUW?

(Greg Covey) #35

Thanks, Anthony. All the information is in post #2 above where it says, “Bix3 with APM Plane Upgrade for QuadPlane”.

I’m still using the stock Bix3 motor, ESC, and prop for forward flight on a 4s 2800mAh Zippy 30C pack that weighs 10oz.

The quad motors are iPower 2212 1000kv motors and Next Level 20-amp ESCs. Altitude Hobbies used to sell them for $8 but I see the price has gone up to $15 now.

The total flying weight goal was 58oz so I am close to that or a few ounces under.

(Expntly) #36

Thanks that’s helpful.

Are you happy with the size of the 2800mAh? Some numbers on the flight time you get in quad and fixed-wing would be helpful. I went with a 5200mAh 10-20C but it’s heavy and the C ratings are actually a little low. I’m thinking of getting one with higher ratings, and maybe even lower capacity to save weight.

(Greg Covey) #37

For me, the Bix3 is just a QuadPlane experiment to get my “feet wet” with the concept. My feeling is that the QuadPlane has the potential to take both the complexity and cost out of traditional VTOLs using a tiltrotor or tiltwing. In this manner, the Bix3 will be used for testing QP features and performing demos at events so the 4s 2800mAh pack provides plenty of time and balanced the plane like the original 3s 4000mAh pack that I used on the stock plane setup.

I opened a new thread for my Ranger EX QuadPlane conversion. This QP conversion will be productive for mapping and video. I believe it can easily carry two payloads and still use 8AH to 10AH packs. Time will tell…

(Greg Covey) #38

My first autonomous mission with the Bix3 QuadPlane was very successful. I used the same simple 8 command mission that I originally used on my FireFLY6 VTOL. Only the first two commands have text wording changes. The same two issues (as previously reported) were seen during the Hybrid RTL process. The LAND_THR_SLEW value change didn’t seem to affect the “porpoise” issue but the Q_LAND_FINAL_ALT setting change from 6 meters to 3 meters directly affected when the drifting started on final descent.

Bix3 Hybrid RTL Settings:

  • Q_RTL_MODE =1 (Hybrid)
  • ALT_HOLD_RTL = -1 (keep same altitude)
  • Q_RTL_ALT = 15 (meters)
  • RTL_RADIUS = 50 (meters)
  • WP_LOITER_RAD = 200 (meters)
  • Q_WP_SPEED = 500
  • Q_WP_SPEED_DN = 150 (initial descent speed)
  • Q_LAND_FINAL_ALT = 3 (meters)
  • Q_LAND_SPEED = 50 (cm/s)
  • LAND_THR_SLEW = 120 (percent)
  • THR_SLEWRATE = 100

(Expntly) #39

Great Greg!

The DO_VTOL_TRANSITION doesn’t have the first param set, is this normal?

For the landing issue, do you also have it with VTOL_LAND?

(Greg Covey) #40

Hi Anthony,

I hadn’t noticed that the DO_VTOL_TRANSITION needed a parameter so apparently the default allows you to go from Hover to Forward Flight modes. This is nice because it is consistent with my FireFLY6 mission plans. See my other thread on QuadPlane Autonomous Missions.

I have not tried VTOL_LAND, only QRTL and Hybrid RTL which both had the same two issues.

For mapping, the QuadPlane setup seems to be the same as on the FireFLY6 Planner. My Bix3 doesn’t have retracts but this is also taken care of automatically on the FireFLY6 missons. I haven’t checked to see how the QuadPlane works.