Quadcopter went up and waved away in althold mode log

this evening I fly my quadcopter but is behave unnormal, I noticed I must give throttle top up to take off
late two times, I found it went up suddenly nearylly out of control, the last time, it went up very quickly and waved away, I can not control it. it crashed into a wet place.
I tried to take it back, now I upload the log files,
please help to analysis what’s the problem.

PS. I have fly it for 2 weeks…

I’d start by setting your RC3_TRIM parameter to 1016 (unless your transmitter has a self centering throttle stick) and turning up the logging to include imu as there isn’t a lot of data in your logs.

Thank you MarkM,let me give more details:
I have fly this coptor for nearly too weeks,
it flys well, I test stablize, loiter,althold,Land and Return home mode
last evening i installed 4 new props,as the old ones been used by my new hexcoptor,
i fly it first down my building,what i can fell unnormal
is i must push the throttle complete up to make it take off in althold mode, but in the air, it follow my rc,
then i went out to a big place, as gps can lock there, i switch to loitor mode.
it can disamed, indicating gps lock ok, but last 2 times i found it going up quickly not as my throttle,
and the last time it even waved to the right in a high altitude
As i felt i can not see it and control it,i switch to land mode,hoping it comedown but not wander away cause damage
i heard a sound saw its flash led in distance later.

Before the last crash, when it land,the motor continue run even i try to disarm it or put throttle to botyom,
Several times,it even try to move on ground.

I use misdion planner but not very familiar,
can i check the throtyle in and altitude,speed to see some unreasonable behievior…

Most likely too much vibrations, you could fly in stabilize mode.

Viberation should not make "go up outoff control"
I feel should be something wrong with throttle control
Can you check out some unusual in the log file?thanks!

Did you use the same size props? Changing prop size and or pitch, without changing anything else, can cause lots of strange problems. I recently tried some 6X4.5 props on one of my 250 quads. It was setup for 5/4.5 and has a Naza Lite flight controller. When I went to half throttle, it took off like a rocket, and I had to pull the throttle down to zero, to stop it. Which it did when it cut the motors! I could have connected to the computer, and reset things, but it was OK with the 5" props, so I put them back on. :open_mouth:

Changing the props without balancing them could very well cause excess vibrations. These vibrations confuse the FC and it will fail to hold altitude because of it.
The only way round this issue is to fly in stabilize only or, more preferably, get rid of the vibrations.

The next day, i clean ed and checked the apm, receiver…i re~calabrited the 4 Esc, check the props, then i checked the apm settings on mission~planner, nothing unusual except the fly mode change in ch5, i change 1 of the 3 from Land to Stablize, then i turn on the isu recording in log, as suggested by MarkM. I alse follow Viberation detect wiki to record and check how about the viberation…
Then i went down to test it, i fly it in stablize mode, took off the ground only 2 meters, it fly well, i repeat another time…
Then problem followed, when i text the 3ed time, it tilt to one side, one motor turned unusual, to find the problem, i didarmed it put a little throttle and carefully took the coptor in my hand tilt to different directions to check the motors , the Motor seemed wrong run slow obviously than the other 3 but i found it still can increase run speed when tilt to its side.

Based on this, i suppose the problem may be:
2,prop and vibrition
3,esc or motor
4,even the battery because i was using the same
cheap 2200 battery recharged.

This evening I checked the ESC+Motor and it is OK, then I connect the APM to Mission Planner, and found even I put the coptor level, Mission Planner show it tilt a lot. — This was the problem.
after I re-calibrate the Accelerometer again in MP, I test it and it now fly OK.

Now I think the problem maybe every time the Coptor drop on the ground hevily it must damaged the APM board ( I did find the case is damaged), so I think last ‘waved away’ should be some thing wrong caused by this ‘heavy’ drop.

Now I believe the problem is Vibration! MarkM and Andre-K is right.
Because after that , I installed a new F450 quatcopter, it flew well in stablize mode, but when test is in althold mode, it went up quickly just like the previous one. I then checked found the major differences with my previous successful installation is I didnt use a “Vibration dampening pad”, after I added ont, the quadcoptera flew well in althold mode.

Mr. cootertwo, yours maybe the same problem, it was not because of the props, but because the new props caused bigger Vibration!

We must following the directions in the APM wiki pages:

Now my 2 quadcopters and 1 hexacopter fly very well with AC 3.2.1.
Thank you all…