Quadcopter Uncontrolled Yaw

I’m helping some students build a quadcopter using APM and a Pixhawk. I’ve built several multirotors myself but never run into this issue.

Upon liftoff the copter will start to spin pretty vigorously. It remains fairly stable in pitch and roll for a few seconds then starts to lose the battle and I land. It usually spins in a clockwise direction but will occasionally spin counterclockwise.

Things we’ve tried:
Verified correct motor direction (we even tried it backwards just to see and that didn’t work)
Verified prop direction (it does lift off)
Reinstalled firmware and went through the compass and radio calibration multiple times
Leveled the motors with each other
Changed Yaw PID settings with no effect
Tried correcting with radio inputs with no effect

At this point I am ready to blame a bad controller or radio. Any other ideas for things we could test?

I’ve uploaded a bin file.00000019.BIN (351.2 KB)00000018.BIN (466.6 KB)

Just a though sounds like an ESC issue, can be just Calibration or a bad esc , to verify you should calibrate esc via controller and then verify that the esc took the min and max values, as for what I’ve seen with Arducopter 3.5 esc cal of oneshot or oneshot125 has to be done manually to each esc via the usbtool after that the copter works.

It has basically shut down motors 1 and 2 and ramped up motors 3 and 4.
So it is a deliberate rotation by the controller.

From your parameters I am assuming you have a quad in X configuration, is that so?
When you rotate the copter while connected to Mission Planner does the compass move in the right direction?
If it occasionally rotates in the opposite direction then I would focus on the compass, but make sure your frame type and class have been set correctly.

It is in an X configuration. Good to know the yaw is being commanded. That should get me closer to solving the issue.
I’ll verify the from settings again and check on the compass.


I did a complete firmware re-install making sure that the frame settings were correct. I recalibrated the compass. I checked that it is moving the correct direction. Same result.

I rarely like to chalk things up to bad equipment but I’m running out of ideas. The compass is a Radiolink SE100 M8N GPS/Compass combo.

It still looks like a motor/prop direction error.
How many compasses do you have active?
If internal and external try limiting it to external only.
I would still look at those motors and props very carefully though.

The EKF is very, very annoyed with your compass. Check your AHRS and compass orientation!


There’s also z-axis gyro drift happening… but that’s probably effect not cause.

SOLVED! Thank you all. I’m annoyed with myself but I’ll admit my mistake. We were using an incorrect motor direction diagram. After swapping props and reversing the motors all is well. I know we tried it “backwards” once but the students did the swap that time and I must not have verified that they executed correctly. After taking time today to do the swap with care and verify that it was indeed reversed it flew very nicely.

1 Like