Quadcopter starts wobbling after Autotune


Can someone please have a look at at my PID’s and TLOG as after I completed Autotune on the Roll and Pitch axis my drone started to wobble in bothe stablised as well as autone.

So I first completed the Roll then Pitch and before I disarmed there was no noticble wobble. However, when doing the Yaw autotune there were constant messaged of the drone not being able to level and that I need to switch to manual tuning

I am using Copter 4.3.7 on a Holybro Durandal FC

Process I used was as followes

Arm in Stablised mode and take off then center throttle
Switch to Althold
Select Auto Tune channel 7
After received message that Autotune is successfull test roll and pitch in Alt Hold.
Land drone and disarm while Autotune still active.


You have 8 logs in that link. Identify one (1) that is relative to this post.

What you are showing there are default PID’s so clearly Auto Tune wasn’t successful if this was taken from a post Auto Tune log. Just by leaving the Chan 7 Auto Tune swicth high does not mean it’s still in Auto Tune if you switched to a different Flight Mode. A common mistake if you made it.

Here is the correct one

There is only one now

You skipped some steps before running Auto Tune. The Notch filter needs to be configured and some other parameters set. Change these:

I would also set Dshot to Dshot600. And your MOT_SPIN_MIN looks way too high. Setting Motor Ranges
Make the changes and do a simple hover flight in AltHold for a minute or so.
There appears to be a mechanical Yaw bias but it’s difficult to tell with an Auto Tune log. But the short section where you are flying in Stabilize shows this.

Would you recommend reverting back to default and then trying again?

During the first flight which was not part of this there was a loose motor which was corrected but there is no visible mechanical yaw in any mode

Yes. Probably a better place to start Auto Tune with the pre requisites met. Defaults + Initial Tune parameters and set the parameters I mentioned then do the hover flight to collect data for the notch filter.

“INS_LOG_BAT_OPT,” There is not option 4 for this

Yea there is. Set it or use the bitmask to do it. It enables pre and post logging.

Ah ok i see thats the last option

Ok so i understand that that nothcfilter does but what does all these settings have to do with the wobble after autotune?

Maybe. It’s likely a bad tune that caused it. In any case this is the right way forward for any craft. There is a lot of useful info gathered from a simple AltHold hover.

Yes but what can be the cause of the poor auto tune

Vibration levels, output oscillation, parameters out of range for the craft, combinations of those. If there is a yaw bias that would need to be addressed. I don’t that mot_spin_min was doing you any good.

What are the components on this?

Durandal FC, 4 x ESCs configure in dshot 300, will 600 today, 530 kv motors with 12 inch props on a 6s 6000 mah liIon pack

There were no yaw error messages while flying