Quadcopter Only Arms w/ USB Attached

So I finally have my quad put together and everything seemed okay, but I cannot get the quad to arm without the USB cable attached to the APM. I am running Arducopter 3.2 on an APM 2.6, Turnigy 9x Tx/Rx, and HobbyKing Blue Series ESCs.

When the USB cable is attached to the computer, the quad arms as expected and I am able to raise the throttle and the motors all spin accordingly (first video below). However, when the USB cable is removed, the motors just give a quick spin when trying to arm and then do nothing (second video below).

In trying to work through this, I figure the USB provides two things: communication and power. I can’t figure out why the direct communication would help, but perhaps it’s a power issue? I am using the 3DR power module.

Please let me know if anyone has any ideas on what to do. Thanks!



Well, I’ve solved it.

I hadn’t calibrated my power module, so it was reading the battery voltage 2 volts lower than what the battery was actually providing. I imagine every time the motors started the voltage dipped and the APM shut them down. After I calibrated the power module everything worked great and I took my first flight.

Sorry dumb question… I am having the same issue, did you calibrate the apm power module or the esc modules? Thanks,

He clearly stated he calibrated the power modules