Quadcopter frame of reference in SITL

This might be completely trivial, but I haven’t found an answer yet.
I’m running Arducopter SITL with the command line
$ ./ArduCopter.elf --home -35,149,584,270 --model quad
I’m interfacing with the simulator through matlab and mission planner via TCP.
I noticed that by default the x-y axes of the copter are oriented to coincide with the copter arms, such that zero yaw\heading points along the copter arm (orange line in image).
This is a 45 degree shift from the reference frame I want to use, such that the zero heading will point along the blue line in the image (From my understanding, in the conventional body-fixed reference frame the x-y axes are rotated by a 45 degree angle from the copter arms).

I assume this all has to do with the model of the quadcopter that the SITL is simulating.
How do I rectify this?
I want to avoid compensating all my rotations with a 45 degree yaw angles shift.



Default quad vehicle is in + configuration, use -f X instead for a x quad configuration !

I Tried
$ ./ArduCopter.elf -w -M x
Creating model x at speed 1.0
But I get the same result, a ‘+’ model. Note that I looked at the param list and indeed FRAME_TYPE=1.
Anything else I should check?

After looking at it some more, the graphical representation of the quad in mission planner didn’t change, but the coordinate system did rotate by 45 degrees. I also had to change the compass orientation to YAW90, otherwise reported attitude was off by 90 degrees.