Quadcopter flips on take off (solved)

I am incredibly new to Ardupilot. I have read over the wiki and all documentation I can find multiple times during my build. I thought I was done and just need to auto tune and some P.I.D. tweaks to go flying. I was wrong. It seems my front rotors don’t want to spin up properly. When I try to take off in stablized mode, the drone just pitches forward and flips over it’s nose. If I give it a little pitch back it will try to flip over backwards. I have calibrated my radio and escs multiple times. I have also done the accelerometer and mag multiple times.

I am running a Matek H743 mini flashed to the latest Copter with a TS100 gps/mag and a single tilt servo.
4x racestar 20A esc (BLheli-s light) flashed to the latest firmware. (Multi-shot).

I don’t really know how to interpret the logs I just know they don’t look right. Please help.
1 12-31-1979 6-00-00 PM.bin (856 KB)

That’s usually because the motor order or prop direction is wrong. Did you run Motor Test (props off) in Mission Planner and confirm proper order and direction?
Motor order
Page down to the Motor Test section to understand how it’s run.

Secondly, you shouldn’t even attempt flight before setting the initial tuning parameters (yours are at default). Read about it here:
Initial Tune

And use this tool in Mission Planner:

Thanks for the response Dave. I spent a month out to sea building this. I did do the motor test multiple times. I will admit I think I missed the initial tuning. I have been reading and came to the conclusion I need to check everything again step by step. This is my 1st attempt at Ardupilot and it can be confusing at times. Thank you for the link. I will double check everything.

Just make sure it runs in this order and direction in Motor Test when you hit the A-D buttons. This is often misunderstood.


Looks like I need to update MP. I missed the initial parameters set up because I don’t have it. I have frame type then accel calibration. And I don’t know how I screwed it up but my motor s are out of order. I get that fixed and see what happens.

90% of the time that’s the problem with what you described. Even after claims of “triple checking”.

From Mission Planners Help screen hit the button on the bottom for “check for Beta updates”. Plan on doing this regularly to keep up with features. Mission Planner lags Ardupilot by a good bit.

A Post title edit would be good. This one draws like a magnet and it has nothing to do with understanding logs.

Well that was it. Motors in wrong order. I thought they were correct so I went to the logs to see what the motors were doing. Thank you for your help. Will update post title. Ok how do I update post title? I don’t see an option to edit it.


Fixed it for you.

1 Like

50 01-01-1970 01-00-00.bin.log (233.1 KB)

Are suggesting that this is an Arducopter 4.0 log file? In any case why are you posting it?

Sorry I didn’t notice that, I’m new in this forum