Quadcopter flips after in-flight compass cal and reboot [SOLVED]

Hey All! I’m running the latest master build and the latest MP beta. My new build was drifting pretty badly in loiter, verging on full on toilet-bowling. I’m able to do a normal compass calibration without any issues. In the past when I see loiter drift like this I’ve corrected it with an in-flight compass cal. I completed an in-flight compass cal, land, reboot, and arm. When I try to take off it immediately flips on the roll axis. Here are 2 logs. One is the log from the compass cal flight. The other is the flight after reboot, where the quad flips. Any idea what’s going on?


I recalibrated the compass, flew it in althold, landed, switched to loiter, tried to take off and it flipped. So I don’t think it’s a compass issue?

Have you checked your motor/ESc’s?
The RCout shows M4 going to max and so M3 is shut down.

I have but I’m about to check again.

This issue was due to a flipped flow sensor. I didn’t build this unit and was unaware of the change.