Quadcopter Flip on Take-off


We have a quadcopter we’ve built using Emlid’s Edge flight controller. We went through the processes to calibrate ESCs, compass, accelerometers, etc (seemingly) successfully. Everything looks well calibrated (according to QGroundControl). Whenever we attempt to takeoff, the drone flips over on its side pretty much instantly. It doesn’t get even 6 inches of air. It is a fairly large quadcopter (550mm frame).

We have double and triple checked the prop directions and motor spin directions and they are correct (FR, BL counter clockwise, FL, BR clockwise).

I’ve attached logs below as we are pretty new to this and I’m sure people on here know more about how to diagnose the problem than we do. Any help to diagnose why this is happening would be helpful.

Whatever other information I should’ve provided please let me know.

Logs: https://drive.google.com/file/d/1BMe22DTf-mnJ03LHQEyMBkx7DPLcAnry/view?usp=sharing

Kind regards!

Do the motors spin in the correct order when you run Motor Test from Mission Planner?

They spin in Front-Right, Back-Right, Back-Left, Front-left order (clockwise). As far as I know this is correct, despite the motor numbering being different. Same result in QGroundControl.

They should spin in CW order A,B,C,D (FR, RR, RL,FL) in MP Motor test. Or 1,4,2,3

Yes this is how they behave.

Yea, I see I just repeated what you wrote. It’s odd because if you plot Desired Roll Vs Roll it shows its being commanded to do that.

Weird. Yeah pitch and yaw line up too. All I tried to do was raise the throttle to takeoff in stabilize. This happened twice. Would the light logs from the second flight be helpful? I have the .bin files as well if those are helpful (I’m not sure of the difference between the .log and .bin).

The counterclockwise props are slightly stiffer than the clockwise ones, but are the same size (12x4.5’’). Could this be a factor?