Quadcopter crash using loiter mode


I have a quadcopter frame 450mm, using pixhawk fcu. Some weeks ago I was testing the loiter mode and was working very well. After some time, I try again with the loiter mode. The quadcopter takeoff ok, but after some seconds it lost orientation on pitch and roll and start to lose height and then I land it.

I tried to do all calibration again but the problem persist.

I tried to figure out what happened using the log files but failed. Someone could help me?
This is the link to the log files.

Thanks in advance.

You definitely have some issues but it is not exactly clear what they might be.
From the RCout there seems to be a balance issue as you can see from the operation of the motor values.
Also RC3 is maxed out most of the time it is flying.
I would check your balance, and look at motor 3 for wiring, loose prop, something physical.
Your CW props are not working nearly as hard. Motor misalignment?

If you look in your ATT roll/pitch you can see the controller fighting but the frame instability gets away from it.

I thought maybe power supply but you don’t seem to have calibrated your voltage measurements so I cant tell.
From the increase in amps though it does look like the battery may be struggling.
If you cant supply the power then the FC has no chance of stability, although the RCouts are climbing with lower altitude gain they are not ALL maxing out.

I don’t think the mode had anything to do with it.