Quadcopter ALWAYS tilts backwards

I’m having a problem with a quadcopter which has the 3dRobotics APM 2.6 board.

It keeps wanting to tilt backwards.
I’ve followed all the setup instructions that there are in detail.
I’m using the quad firmware and have it set up as an “X” configuration.
I’ve calibrated all my ESCs correctly.
I’ve calibrated the accelerometer.
All the engines are connected to the correct channels on the APM. The reciever is also connected into the APM’s input channels correctly. (channel 1 into channel 1, channel 2 into channel 2 ect…).
I have the motors set up according to these instructions using the “Quad X” configuration.
Channel 1 is connected to the motor in the front-right (which has a pusher prop). Channel 2 is connected to the motor in the back-left (which has a pusher prop). Channel 3 is connected to the motor in the front-left (which has a normal prop). Channel 4 is connected to the motor in the back-left (which has a normal prop).
All the motors are also spinning in the correct direction according to that diagram on that webpage in the link.
The APM is facing forward like it’s supposed to.

I’m trying to fly in stabilize mode.
Whenever I try to increase the throttle without messing with the other sticks, it will just do a backflip into the ground without getting into the air.
If I pull back on the pitch all the way, it will go straight up without falling over. If I let go of the pitch, it will tilt backwards at almost a 90 degree angle and just keep going backwards like that until I cut the throttle or it crashes.

If I look at the failsafe screen in mission planner, it shows the transmitter channels and the APM channels.
When you increase the throttle, it shows that it has the front motors spin faster than the back motors unless you pull back on the pitch on the transmitter or hold the quad titled backwards at about a 45-65 degree angle.

Does anyone know how to fix this?? It’s driving me insane. I already asked about this on the 3drobotics forums but no one could help.

How about providing tlogs and/or data flash logs to help troubleshoot your issue.

Yeah here’s a bunch of logs. I’m not sure what to look for.

You will have to redo the test as the default logging for APM is too low to be of any use.

You need to set LOG_BITMASK = 43006 so we get all the data.

When everything works set it back to the default 890 I think as it will slow down the APM board.

copter.ardupilot.com/wiki/config … og_bitmask


Aw man that’s disappointing. The problem is that in the last flight, I crashed (lightly) and broke my frame.
It’s a predator 650. It twists all around and won’t stay straight. I tried tightening all the screws, securing it with twisty ties and then using zip ties but it just won’t stay stiff anymore.

Don’t ever buy a predator 650 frame btw. That frame is really weak for something made of carbon fiber.

I guess I’ll post again in 2-3 weeks after I receive a new frame. :frowning:

I’d recommend before doing any further flight attempts to get someone to help you. One of you holds the copter over his head and the other arms and tries to give some throttle. It should be easy to see which way wants to go and hold back a little to see if it wants to stabilize.
Which flight modes have you tried btw? I would recommend to start with the first flights in acro if you are comfortable with it as the copter would not try compensating for level angle

Was the quad perfectly level when you did the 1st accelerometer calibration?
Have you checked you centre of gravity is correct?