Servers by jDrones

Quad Unable to Arm Pixhawk, Copter 3.5, AT9S Transmitter

So far I’ve been unable to arm using the transmitter. The Quad boots up, finishes all pre-arm just fine, but holding throttle to bottom right doesn’t arm. I CAN arm it using Mission Planner. It also disarms just fine using the transmitter to bottom left. I just can’t get it to arm. I’ve tried reinstalling firmware and software, going through configuration repeatedly, and manually tweaking maximums. Nothing has worked for me so far.

Any ideas?

It’s an ESC problem believe it or not.

I had this exact same problem, luckily I think I have your solution.

You need to (re)calibrate your ESCs, manually.

Plug each into receiver in port 3 one at a time with everything on and the receiver’s throttle at max. (remove the blades) Your ESC should beep a little song, then move the throttle to the bottom, you will hear a confirmation tone. Do this to all your ESCs.

Hope this works. Sounds just like my issue.

~Also, reverse the throttle on the receiver if you haven’t yet.

Servers by jDrones