Servers by jDrones

Quad setup feels not much sturdy. version (4.02)

Hello, i am testing out a custom rig today. it was windy I have made some changes in the full parameter list after reading the Tuning Process Instructions
I have encountered a few issues while flying

  1. The quad doesn’t feel sturdy enough in GPS mode
  2. when i am trying to YAW it wobble
  3. It feels very light and can easily drift way
  4. i have earlier performed the autotune on it with some 300-400gm payload attached it fly very stable that time so to check this was not a problem i attached a temporary weight to it which was aluminum spay can after adding the weight it feel bit stable but suddenly it entered fail-safe. i have checked the logs its says GPS glitch.
    i am attaching the logs pls review and help me find any other issues

These are the parameters i have changed before the flight
MOT_THST_EXPO : 0.65 for 10 inch props to 0.64 for 9.5 inch props
INS_ACCEL_FILTER: 20Hz
INS_GYRO_FILTER: 40Hz for 10 inch props tp 42Hz for 9.5inch
ATC_ACCEL_P_MAX: 110000 for 10 inch props to 115500 for 9.5 inch
ATC_ACCEL_R_MAX: 110000 for 10 inch props to 115500 for 9.5 inch
ATC_ACCEL_Y_MAX: 27000 for 10 inch props to 28400 for 9.5 inch
ACRO_Y_P: 4.5 to 12.8
ATC_RAT_PIT_FLTD : 20 to 21
ATC_RAT_PIT_FLTT : 20 to 21
ATC_RAT_RLL_FLTD: 20 to 21
ATC_RAT_RLL_FLTT: 20 to 21
ATC_RAT_YAW_FLTE: 2
ATC_RAT_YAW_FLTT: 20 to 21

Here is a link to the logs in which fail-safe occur
https://drive.google.com/drive/folders/1IclXqi-AIPQZuiIztk_y98S4K51zSH8q?usp=sharing

Here is the link to the video in which you can see the drone flying characteristics
https://drive.google.com/file/d/18m8QhsM7cqrDUUMF3oVNz3AfZOJMKt88/view

Set INS_GYRO_FILTER to 20

Sure, can explain to me what could be the cause of the problem.
Plus i also want to know whether i should autotune with added payload which this quad has to carry or without the payload?

Plus what causes the problem of wobbling when i am trying to yaw.
here link another video
https://drive.google.com/file/d/18foPHKZ5J2pe4OC_EOMzbDKw68nYv1i2/view?usp=sharing

How can reduce the rate of Yaw it’s too aggressive?

I also need to change the below values according to the new INS_ACCEL_FILTER value

ATC_RAT_PIT_FLTD : 20 to 21
ATC_RAT_PIT_FLTT : 20 to 21
ATC_RAT_RLL_FLTD: 20 to 21
ATC_RAT_RLL_FLTT: 20 to 21
ATC_RAT_YAW_FLTE: 2
ATC_RAT_YAW_FLTT: 20 to 21

You can leave all them how they are.
Maybe describe your craft better - what size props and so on, It looks fairly small in that video.

The props where 9.5inch Self-locking ones.
size is around 480mm
flying weight is was 1.05kg (It feel very light to fly)

Plus i also want to know whether i should autotune with added payload which this quad has to carry or without the payload?

can you also check the log and tell me the fail-safe was triggered?

@dkemxr
Hello sir can you pls check the logs?

Flight controller i am using
https://shop.holybro.com/pixhawk-mini_p1078.html

Autotune without any additional weight, leave off any cameras, gimbals or payloads.
Have you done another flight with INS_GYRO_FILTER,20 ?
If so send the link to that .bin log file.

yes
https://drive.google.com/drive/folders/15cLGl5tn_WRK8Y0o32XSW0ELbC2Ys7Bu?usp=sharing

What was your observation of this flight?

You didnt get suitable GPS 3D fix till about half way through the flight, so I suggest you either make your self a rule of only every trying arming in Loiter mode (even if you dont wish to takeoff in Loiter), or set these:
FENCE_ACTION,3
FENCE_ALT_MAX,120
FENCE_ENABLE,1
FENCE_MARGIN,5
FENCE_RADIUS,600
FENCE_TYPE,3

You pitch and roll is a bit wobbly, not tracking so well. Try these:
ATC_RAT_RLL_P,0.15
ATC_RAT_RLL_I,0.15
ATC_RAT_RLL_D,0.007
ATC_RAT_PIT_P,0.15
ATC_RAT_PIT_I,0.15
ATC_RAT_PIT_D,0.007
ATC_RAT_RLL_FLTE,0
ATC_RAT_PIT_FLTE,0

For a softer RC feel, a bit easier to control, you can set:
ATC_INPUT_TC,0.2 or even 0.22

And try this to reduce yaw aggressiveness:
ATC_ANG_YAW_P,6
ATC_ACCEL_Y_MAX,16000

Try that in AltHold mode again - carefully.
Do a small flight and see if it’s nice and steady, or if motor noise is strange or motors get hot.
If it seems OK, move on to Autotune.
Set a flight mode as Autotune, takeoff and fly around in Loiter, if all OK switch to Autotune mode. Once it finishes twitching, bring it back, land and disarm WITHOUT switching out of Autotune mode.
Use the AUTOTUNE_AXES parameter to do Yaw then pitch and roll individually, that’s easier on the battery in these early stages.
Once they complete, do a Autotune of all axis together which will really fix it up and usually runs a bit quicker.

done a test flight not holding the attitude accurately

https://drive.google.com/file/d/1-59tgyGEnXbH2HB-X4TFBDEsU8wbsngx/view?usp=sharing

here are the logs
https://drive.google.com/drive/folders/1EsOclOxoqHj1RMul45L2D43KtUWiUFXb?usp=sharing

Your arms or motor mounts are twisted, causing CW motors and CCW motors to be fighting each other. This will be detracting from stability, especially yaw control.

Your X and Y vibrations probably mean your props need balancing, but your Z vibrations are definitely a problem (showing clipping) and you’ll have to do something about the flight controller antivibration mounting and secure any wiring. Make sure the wiring is not pulling on the FC or vibrating against it. Secure everything.

After you’ve done work to fix vibrations, but before you fly set these:
PSC_ACCZ_I,0.396
PSC_ACCZ_P,0.198
BATT_ARM_VOLT,14.7
BATT_CRT_VOLT,14
BATT_LOW_VOLT,14.4
BATT_FS_CRT_ACT,1
BATT_FS_LOW_ACT,2

And these ones that you didnt set these last time:
ATC_RAT_RLL_P,0.15
ATC_RAT_RLL_I,0.15
ATC_RAT_RLL_D,0.007
ATC_RAT_PIT_P,0.15
ATC_RAT_PIT_I,0.15
ATC_RAT_PIT_D,0.007

The parameters I put in here can be copy/pasted into a text file, like Notepad, and saved as a “{something}.param” file and loaded via MissionPlanner to save making typing errors.

so now i have i mounted the flight controller on the vibration damping foam instead of o rings and i think this method is working fine now.

i have also tested the the after this with the above setting but the oscillation were very high. i am attaching the logs of the flight below.
https://drive.google.com/drive/folders/1d7VLNSXgxJlbLvUU4q_qSmSEvdp9Al7z?usp=sharing

After that flight i have also done another flight with some lower PID values and the oscillation were not noticeable i feel some oscillation when going left and right one think i notice was motors feel warm should decrease the D value ?
i am also attaching the log for this flight.
https://drive.google.com/file/d/1J7ohOJREksswylFaqogQdSewAAAQtAft/view?usp=sharing

OK you’ve done a great job there - vibrations are really low, motor outputs are extremely closely balanced, pitch and roll are quite good…

Probably keep P and I terms matched and lower D term like this:
ATC_RAT_RLL_P,0.08
ATC_RAT_RLL_I,0.08
ATC_RAT_RLL_D,0.003
ATC_RAT_PIT_P,0.08
ATC_RAT_PIT_I,0.08
ATC_RAT_PIT_D,0.003

Being a small aircraft I think you’ll want to increase this:
ATC_ACCEL_Y_MAX,40000

And you can now set these:
ATC_THR_MIX_MAN,0.5
PSC_ACCZ_I,0.3
PSC_ACCZ_P,0.15

See how that works, and run autotune one axis at a time - you’ll have to test Loiter mode before you do, to ensure the aircraft can hold position.
Probably do Yaw autotune first, the safest option.

  • arm and take off, try Loiter mode, switch to Autotune mode
  • wait for twitching to finish
  • DONT change modes, just bring the aircraft back and land, disarm.
  • wait a few seconds for new parameters to save

Recharge the battery and Autotune another axis, or both Pitch and Roll together.
Once all three axis are completed OK and you’ve done a few test flights (and gathered more logs) you can run Autotune again, all 3 axis at once - it wont take as long as the first time.

Sure i will do. I want to know a few things

  • Should i do autotune in loiter mode or Atld mode?

  • How to enable single-axis to autotune which para i need to change?

  • Should configure harmonic notch filter before the autotune or after it ? or does it even necessary?

  • Most important question
    I have to attach a fixed payload box to the drone earlier i have done autotune without any payload but after performing all the tuning. i tested the setup with payload and it feels very unstable plus it got crashed in the crosswind. it was trying to hold the position but feels very unstable. This was all before i have changed the vibration padding.

@xfacta i have figured out how to enable single-axis to autotune.

Sorry for being too curious but I have already crash 2 drones while configuring so…
can you pls answer my rest questions.

Test LOITER mode before switching to Autotune mode - Autotune uses a loose loiter or position hold system but you want to make sure your copter can do a position hold (LOITER) before you start Autotune.
I usually start with AUTOTUNE_AXES,4 to do yaw only and see what happens. Leave the other Autotune parameters at defaults.
Depending on how you go for flight time and battery use, you can do pitch and roll separately or together.
Once Autotune is completed and you’ve done a test flight (and the new tune is working well) do another autotune with all three axis at once. You can do as many autotunes as required on different axis, but best to do all three at once. Autotune should be quicker each time as it gets closer and closer to ideal.

Post a link to a new log - do a bit of hovering in ALTHOLD mode and some gentle flying around with pitch and roll stick movements. If everything is going well, you can try some more aggressive pitch and roll stick movements and release the stick so it centers itself and see how the craft reacts.
LOITER is good to test too, it’s probably going to be your most-used mode. - LOITER will be different to ALTHOLD since it is a “smarter” mode that can look after itself more. ALTHOLD is more like STABILIZE without the manual throttle control.

Once Autotune has done it’s job and your craft is flyable and safe, it doesn’t have to be perfect, then move on to the Harmonic Notch Filter. That’s a whole other story…
After that’s set up and working, run another Autotune!

It is a long road and it sounds like hard work, but the result will be GREAT provided you’ve got no other mechanical or electrical issues.

Hey Shawn hope u are doing well. Can u pls explain me what these parameter in particular related to ? what they actually do?

Servers by jDrones