Quad set up has poor alt hold

I have a quad that can’t seem to do alt hold very well. I have had all the components on another frame [ pixhawkand etc ] without a problem. This new quad frame is probably %25 heavier. It seems that weight is the issue? I have 800 kv motors 5000 mah 35amp lipo 35 amp ESC’s. I have tried increasing the alt-hold pids [ up to 3.0000 ] but didn’t really help. I am considering getting bigger motors. 4 Tiger Motors 1100KV. Does that seem like a reasonable approach?? I don’t have a way to measure the quads weights very well. Another thought is the pixhawk is inside a quacopter frame i.e. water proof. However I am using the breathable cover and also I had to drill a hole for the gps wires and it’s not caulked yet so it sure seems it can breath good enough for that. But perhaps there is something about the setup that’s effecting it more than I know. I would appreciate any thoughts on how to make it better.

Have you run your set up through ecalc to see the thrust to weight ratio? I would run it through both ways, the old weight, and the new weight, compare the two relative to the response you are getting just to see if it is reasonable that the new heavier frame could cause the problems you are having. Also, I would try saving your settings to the pixhawk, and then re-flashing it to default, then manually inputing your parameters in again. just a thought before you spend money. Hope this helps

@wootenelli Thanks I did make it better via changing Pilot_Velz_max too a higher value [500 from 250] so my throttle input had more effect in alt hold and loiter. And I had to lower Trim_Throttle to a lower number so so it didn’t rise a lot when switched to alt hold. I think if I had bigger motors I would not have had to change the trim throttle.

What precisely do you mean by, “…can’t seem to do alt hold very well”? Does it not hold a constant altitude, moving up and down? If so that’s almost certainly vibration and you need to do a better job isolating the controller. Is it that it doesn’t respond to your inputs quickly enough? That would be a tuning issue, or possibly your quad is underpowered. What percentage of throttle are you at when you hover? If it’s above 65% or so, your power isn’t enough.

I have a couple problems although I think I have one of them resolved. When I first click alt hold it shot up a lot. This is when it was hovering at about %65 throttle [ should be %50 I know hence the thought it’s too heavy for the motors ]. The other issue is my throttle inputs seemed to have much less effect than on my other much lighter frame. When it shot upwards I had to bring the throttle down to around %30 before it would start to lower. I noticed this thread here aquacopters.com My controller is held against the top cover via being sandwiched with 4 small bolts. Maybe it’s not isolated enough?

Your jumping up was definitely due to your throttle_mid not being adjusted correctly. What I do, on the very first flight of any new copter, is just lift it off and hover it for a few minutes. Then I look at the log at the throttle out value and see what it takes to hover. That’s what I set my throttle_mid for.

Your 2 or 3 meters altitude change is almost certainly Z axis vibration. Do a flight with your vibration logging turned one and see what levels you are getting (Enable IMU). There’s a very good section here in the Wiki on measuring vibration with another link to controlling it. From your description your controller is not isolated enough. Once you take such simple steps as mounting it on Zeal tape, the hover becomes rock solid.

Thanks other hand I really appreciate your insights. I can’t wait to get back to my quad and check out your link about vibration. I noticed balancing my props made a noticeable difference as well. I have not tried carbon fiber props but now that I don’t crash every other flight I might try them. :smiley: