Quad-rotors with APM2.8 - Tendency to capsize

Ciao a tutti!!!

I’m trying to assemble and learn to fly a quad rotor based on a clone APM 2.8 (I discovered that was not an official APM only after having received it) - firmware copter 3.2.1.
I selected EMAX MT2216 as motors and Emax Simon K Series 20A as ESC.
My radio is the basic HK one.

I’ve assembled the quad and I tried the first flight without success. I experience the following:

  • On ground without blades installed the engines, when armed, seem rotating at different speed even if I did the manual calibration of each ESC
  • With blade installed, when trying to take-off, the motors on the right side appear to have more thrust than the ones of the left side. I tried to give maximum thrust at once and the quad capsized.

I’m newvie of the APM so I don’t know what to do to solve the issue! I’ve saved my param and my log of the mission. You can download them from my dropbox at the following link:

Please help me!!! :blush:

You haven’t mentioned anything about the checks you’ve done so I will ask the obvious:
When armed and with the throttle at around a quarter (NO PROPS) if you tilt the copter to the left do the left motors speed up and the right motors slow down?
Same for forward, back and right?
Same test but using the RC, if you roll left do the right motors speed up and the left motors slow down?
Same for forward, back and right?

Generally on the ground you will get the motors at different speeds, thats not a problem, only in the air is it a problem.

Have you done all the calibrations?
Compass, Accelerometers, Gyros?

Yes, I’ve done all what you are telling!
Motors change speed moving the quad and also using the RC. Before the first flight, when I Installed external compass and GPS, I’ve cleaned the APM installing the rover FW, then I put back the copter FW and done all the setting and calibrations through the wizard procedure!

No one can help me?

Yesterday I did the followings:

  • Manual recalibration of each ESC. Now I’m sure that the motor output is configured in the same way for all the 4 units.
  • Checked the correct rotation and numbering of the motors
  • Fixed the blades using Loctite Threadlocker because vibrations (I think) caused blade cap nut losses and blade detachment from the motors shafts.
  • Replaced the 4 blades beacuse they resulted damaged from the last flight tentative.

The capsize tendency on the roll axis seems reduced, but now the same problem is experienced on the pitch axis too…

Can you please help me? What are the next step I should follow? As stated in my first message I’m newbie of the sector…

Today I will remove the GPS and the External Compass and restore the internal one, Could this help to solve my problems?

Please help me!

No mention of the “flight mode” you have set…

Make sure you’re in “Stabilize” flight mode and not “Acro”…

(What you describe is what many experience when they try “Acro” flight mode first…)

Hope this helps, Jack

Ciao JBWoolly,

The first thing I did last time once armed the motors was to select stabilize mode before increasing the thrust.


Based on my experience, accelerometer calibration is crucial to achieve success

Please repeat keeping the aircraft completely still during process

At least in my case, this is the difference between day and night


On new builds one of the worst things I find is trying to takeoff too slowly.
You need to give it a punch off the ground, but not too high, just a metre or two.

Also, have you checked the alignment of your motors?
All the props on correctly?
Just all the obvious stuff.

I am new to the ArduCopter system as well, but not new to flying just about anything with wings or rotors on it. I did find some things that are necessary to check with ArduCopter, and one of those is to make sure you don’t have a transmitter channel reversed. You may not have reversed Channel 2 in your transmitter, but with most it must be reversed to work with a quad-rotor using “airplane mode” in your transmitter. Channel 2 is the pitch control.

Since you are taking off in Stabilize Mode, only you as the pilot can provide pitch and roll input during takeoff and provide attitude correction until the IMU can take over in flight. A new untrimmed aircraft will have a tendency to pitch or roll one direction or the other. At least every one I’ve flown, in any sort of attitude correction flight mode, and including single rotor helicopters, requires instant input from the pilot on takeoff to maintain attitude until the IMU has the necessary parameters to start in-flight corrections.

After you have your aircraft tuned and trimmed, including adjusting motor mount angles, then you may be able to take off just by applying throttle and have the aircraft lift off level and true. But keep in mind that even light wind currents and vortex ring state in ground effect usually cause the pilot to have to apply attitude correction on takeoff with any rotary wing aircraft

As an example, on my latest build - an all aluminum 600-class spinning 1455 props, and my first using an APM flight controller, the aircraft had a tendency to yaw left with gentle throttle input on takeoff. If I use more aggressive throttle and get it out of ground effect on takeoff, then it hovers nice and stable at about 1-2 meters off the ground and the yaw tendency is gone. BUT - the flight controller is compensating for a poorly trimmed aircraft once in flight, as I had different max yaw rates right and left. This required re-alignment of the motors to correct.

There’s other things you can check that will cause a pitch or roll tendency, like static motor alignment, vortex ring state on the props interfering with lift, or frame arms that flex or twist under torque so dynamic alignment is radically different than static, and even ESC timing or a bad ESC or motor. You’ve already mentioned that you have uneven idle speeds. But did you bump up the throttle a bit with the aircraft tied down and check motor rpm’s with a strobe tach? That’s one of the first things to check on a new build to make sure all your drives are the same.