Quad rolls and accelerates without control

Hi, I have a small quad 330mm with APM and latest firmware 3.1 - Quad fly’s beautifully most of the time in all modes, but randomly will roll to maximum angle and accelerate away with no response to TX, this has happened 3 times 1st time in Auto mode, had almost completed the mission then accelerated away, RTL functioned and it landed normally the 2nd time in ALT Hold it went approx. 200 meters then responded to TX inputs again, 3rd time just recently it crashed into trees before control was restored, I am new to RC and APM, I did build this quad myself, so I have tried to attached the telemetry log but get an error saying the file is too large, can someone please, the log file in Mission Planner does show a GPS error, but I don’t understand why this would cause it to lose control.
Thanks in advance Steve

Please provide tlogs and/or dataflash logs to help troubleshoot your issue.

Hi Please advise which file extension I need to send .bin, .bin.kmz. .tlog etc
Sorry I did say I was new to this.

From the ArduCopter Wiki: http://copter.ardupilot.com/wiki/common-diagnosing-problems-using-logs/

When I try to send the tlog I get this message “The attachment’s file size is too large, the maximum upload size is 2 MB.
Please note this is set in php.ini and cannot be overridden.”


Here is bin File
cannot upload tlog it is 1354kb still get message saying it is toolarge

Hello anyone there, is someone trying to help me???
I have submitted a file but no help no response
I appreciate it is someone time to look at these log files, just some feedback to let me know if anyone is looking would be helpful.

The log you posted -

You were in loiter, and your GPS signal was quite poor to start with. Then briefly your sat count halved from 8 to 4 and your HDOP went from 2.14 to 16.25 before going back to 6 sats and 2.16.
Then it went really wrong and you lost all GPS, no satellites at all resulting in a GPS glitch, then you dropped throttle which was followed by GPS failsafe and a LAND command.

After that there’s a failed attempt to go into DRIFT mode, followed by the quad dropping to -8mtr (below ground level), a BARO error and then a CRASH DETECTION.

Look’s to me like your GPS signal was rubbish to start with and then went completely which meant the quad thought it was nowhere near where it actually was and was trying to get back. Flipping to STABILIZE would almost certainly have saved it.

Here is an Auto Analysis of your bin file:

Size (kb) 339.6923828125
No of lines 4778
Duration -4 days, 1:09:34
Vehicletype ArduCopter
Firmware Version V3.2.1
Firmware Hash 36b405fb
Hardware Type
Free Mem 0
Skipped Lines 0

Test: Autotune = UNKNOWN - No ATUN log data
Test: Balance/Twist = GOOD -
Test: Brownout = FAIL - Truncated Log? Ends while armed at altitude 29.48m
Test: Compass = GOOD - No MAG data, unable to test mag_field interference

Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = FAIL - ERRs found: CRASH GPS_GLITCH GPS FLT_MODE
Test: GPS = FAIL - GPS glitch errors found (2)
Min satellites: 0, Max HDop: 99.99
Test: IMU Mismatch = UNKNOWN - No IMU log data
Test: Parameters = GOOD -
Test: PM = GOOD -
Test: Pitch/Roll = FAIL - Roll (-166.57, line 4738) > maximum lean angle (45.00)
Test: Thrust = GOOD -
Test: VCC = GOOD -

As MarkM has stated in his analysis, it was looking pretty ugly.

Ok thanks very much for the great info, but you have raised a few questions,
1 I believed that once I had GPS Lock then all was good, why would the GPS loose satellites? how can I tell if I have a poor lock or a good lock before I fly?
2 Do I need a better GPS Module, if so what model do you suggest (I think I will get one anyway)
3 The fail on the brownout, does this mean I lost power to the board?
4 If I am in GPS loiter mode and GPS is lost why would it go full roll angle? when flying a mission it doesn’t fly to waypoint that way.

Thanks again for your time, it is really appreciated.


You could lose GPS lock for a number of reasons. Intermittent wiring connection, solar activity, flying in a built up area. The number of satellites is a good indicator and so is the HDOP, low sat and high HDOP is bad.

What GPS are you currently using? I’ve been using the Drotek M8N for over a year now without any issues.

I think the brownout is a false reading from the auto analysis. After the flight; the log show you were doing other things with the quad for almost an hour. When you finally unplugged it the barometer had a false reading of being 30mtr up. Losing power at altitude is reported as a brown out.

It may be down to your settings, or a glitch in the matrix as to why it flew off. When you started the flight you had a good GPS lock which gave accurate position information to the flight controller. As the GPS signal dropped the position accuracy also drops meaning the FC now thinks it’s potentially hundred’s of miles away from where it’s supposed to be. It’s reaction to that is to fly back to the position it should be in hence the sudden fly away.

I thought there was GPS Glitch protection to stop that, so not 100% sure.

Have you tried changing the firmware? A friend of mine had issues with 3.2.1 on a tricopter (constantly banked right) but was perfect on 3.2

Thanks MarkM
I am not sure of the GPS make as I bought it from a guy who was building multirotors, but I think I will get another unit.
The reason It was an hour before I unplugged was it flew into thick scrub and it took me an hour to find it, luckily I use Taranis TX and Rx so was able to track it with the signal strength telemetry.
I will have to do some reading on the website, don’t know what HDOP is.

Thanks Steve

Have replaced GPS receiver with Professional NEO - M8N GPS Module Built - in Compass for APM Pixhawk quad is now rock solid, flies missions perfectly with no issues.