Quad Plane Function

Guys I am pretty new to Quad Plane, but not Copter and Ardu Plane. I have my aircraft setup. I am running four quad motors and one pusher motor. The pusher motor is setup just like the plane was setup when I had it in fixed wing mode. As for the quads I have four Hacker Motors with four Castle ESCs. The escs are plugged into the motors like normal. Going out from the ESC we have the red and black wires which go to a PDB. All four ESCs go to this PDB. I pulled the voltage (red) wire out of the wire that usually goes to the Receiver and only have the white and ground plugged into the Pixhawk.

I am using the Quad Plane Guide. I have Quad Plane Enable with 1. I have the four ESCs plugged into Channels 5, 6, 7, 8. Each RC Function is set to 0 as per the instructions if you run a normal configuration like the manual suggest.

I Plug in the pixhawk then plug in the batter for the quad rotors. If I flip to QStabilize I am getting nothing out of the quad motors. If I flip back to manual I am getting my normal fixed wing flight.

What could I be missing from this??? To test to make sure the ESC and Motor works I plugged it into the throttle channel and it does work. I also plugged it back into the orginal channels and if I hit the toggle switch for Channel five or 6 or 7 or 8 I can get the motor to chirp.

I have a feeling it is something really simple I am missing.

Is there anyone out there that could help with this issue? I am assuming not many have done this.

Anyone? Does anyone know anyone?

You mention “Each RC Function is set to 0 as per the instructions…”.

The RCN functions for outputs 5 to 8 actually need to be 33, 34, 35, 36 for motors 1 to 4 respectively.


I have tried both ways and still no luck. I am reading the instructions right though by plugging in channels 5 thru 8? The channels right after aileron elevator throttle and rudder? I see inputs from my controller but all outputs are 1000 for the quad rotors.

This is the same problem I’ve been battling for over a month. Power in manual but no power in Qstabilize or Qhover. After spending 60+ hours on it, I finally gave up and switched out Pixhawk lite hardware stack I was using for a full Pixhawk. Still no luck. I have a little hope as I’m now seeing a quick burst of PWM on the 5 through 8 when I go to QStabilize but then back to PWM minimum. I’ll let you know if I have a break through. It’s been very frustrating. - Mark

After replying I finally got it to spin. Here’s what I did: solve all precheck tab items like the battery monitor. All must be green. turned off any failsafes. Set arming_check, arming_required and arming_rudder to 1. Then I had to recalibrate the compasses. They startup, turn off safety switch, do the rudder arming and at least I’m now spinning in QStabilize, and QLand. We’ll see what happens next. Mark


I found that the Arming set throttle min was the trick to get mine to work today.

Got the motors spinning and tried a test flight today and I think my wings are flexing causing the booms to flex too much. She will not get into a stable hover at all…

Also notice after trying a few hover attempts it sounds like she goes into a esc calibration.

1 Like

I couldn’t get mine off the ground. The left side props (especially right rear) spin at such a slower rate that the plan flips when trying to lift with QStabilize. I haven’t been able to get the esc calibration steps to work. I calibrated the left rear esc using a manual process I fashioned but that didn’t change anything. If anyone has any ideas, please respond to this thread. Thanks.

1 Like

Check out this feed. this is the exact problem im having.
@garlandk @HighFlyer was this ever solved?

Hi, sorry for coming late to the party on this topic. I am in the process of setting up as well a quadplane and have encountered the same issue…motor arms perfectly in RC out 3 (plane throttle) but nothing in RC out 5-8. Is there finally a solution to this? Anyone make any headway? I would appreciate your help.
Thank you