Servers by jDrones

Quad Flips using MiniPix

(John Crawford) #1

Having issues with my MiniPix …
Have tried flying my new build and wants to flip backwards … Stopped the test and brought it in and checked out the motor rotation … What I thought correct motor rotation In Mission Planer for was A B C D would have been like on most quad rotation charts for 1 2 3 4 … After finally finding the correct rotations using the MiniPix … I found the correct order is A1 B4 C2 D3 …
Made the correct changes to my motor rotations …
Then tested again and it flipped on it’s left side … I came back in as a double check and motor rotations were good … props were correct …
I have no clue what in the world the issue is at this time …
Have any of you ran into this same situation? If so what was the fix … Perimeters needing adjusting?

Thanks
Doug

(John Crawford) #2

WOW! … no feedback? …

(Shawn) #3

Got a .bin log or maybe a video?
It’s still sounding like motor ordsr is wrong, or maybe even FC orientation.

(John Crawford) #4

Thanks Shawn for the replay …
Yup could use some help … no one in my area messes with drones so I’m kind of on the learning phase of getting a DIY drone built …

No logs since I do not see where it’s recording in MP … It is downloading info but nothing about it’s ordeal …

I could send you a video on whats happening … I tried to compensate by holding small amount of aileron and elevator for it’s roll over … but that didn’t do any good either …

I have gone through and calibrated the unit and all was good … catch 14+ sats etc … However, I can not link to my Mission Planner from the drone to my cell … Not sure if I have to have another form of WiFi added to the drone or not … but it does pickup via video using FPV goggles or 5.8 rx …

Will send you a video …

Thanks again
Doug

(John Crawford) #5

Took a look at the data logs and they are all garble … nothing you could make out as data…

Here is the video of the flight … tried twice then the ESC burned out … WOW! … nasty smoke …
X500 Reptile FLIP - Bad ESC on one leg

(Shawn) #6

Check this and grab a .bin log file, copy it to a fileshare service like Google drive or Dropbox, and paste the link here.
http://ardupilot.org/copter/docs/common-downloading-and-analyzing-data-logs-in-mission-planner.html

(John Crawford) #7

Thanks Shawn …
No of lines 6262

Duration 0:00:13

Vehicletype ArduCopter

Firmware Version V3.6.6

Firmware Hash 6b88b2ba

Hardware Type

Free Mem 0

Skipped Lines 0

Test: Autotune = UNKNOWN - No ATUN log data
Test: Brownout = GOOD -
Test: Compass = GOOD - mag_field interference within limits (7.77%)

Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = GOOD -
Test: GPS = GOOD -
Test: IMU Mismatch = GOOD - (Mismatch: 0.41, WARN: 0.75, FAIL: 1.50)
Test: Motor Balance = GOOD - Motor channel averages = [1274, 1280, 1279, 1275, 1279, 1275]
Average motor output = 1277
Difference between min and max motor averages = 6
Test: NaNs = FAIL - Found NaN in CTUN.DSAlt

Test: OpticalFlow = FAIL - FAIL: no optical flow data
Test: Parameters = FAIL - ‘THR_MIN’ not found
Test: PM = GOOD -
Test: Pitch/Roll = UNKNOWN - Unknown mode in TestPitchRollCoupling: STABILIZE(??)
Test: Thrust = GOOD -
Test: VCC = UNKNOWN - No CURR log data

May need to try another flight and send the data to you again …

(Mike Boland) #8

You need to post the .bin here so we can have a chance at seeing what is happening.
It sounds like it’s working too hard, so what PWM values get it light before flip.
How does the desired’v’actual look in the log.

(John Crawford) #9

Hello Mike,
I tired to pull it up but the "Data Flash Logs’ has nothing written or saved. I’m starting to wonder if there is a parm setting for that … It’s does not seem to work per design … This has been a tough issue with this MiniPix … I have written the company and they are not much help … Getting real close to abandoning RadioLink all together. I may end up swapping it out for one of my Pixhawks and see if I have the same issues as the MiniPix.
As a note to Shawn … I showed a video of burning out one of the ESCs … I replaced it and then did a calibration on the esc’s again - since I added a new on …
Took it out for a test again and seemed to have done better but then flipped over and another esc burned out … since then I replaced that one … Starting to think the SIMONK30A are not of high quality. Out of buying three of them … Only have one left … LOL! …

(Dave) #10

The default parameter for logging should be saving some logs whether it’s a Minipix or not. What is your LOG_BITMASK value? MP Auto Analysis is not up to date and is of limited value.

Anything generically labeled “SimonK” is likely to be junk. Buy some branded ESC’s with up to date firmware.

(John Crawford) #11

What ESCs do you suggest? … I have some other brands coming in i.e., HobbyKing XRotor Pros for another project I’m working on …

Let me look into the parameter for logging and see … At this time I started removing the MiniPix and getting ready to install the PixHawk FC … I liked the size of the MiniPix for this project I’m on … but it’s a real pain to get to work like it should … been on this for a couple of weeks and still can’t get it to work like it should … so I called for help on the forum to see if anyone had ideas that I may have missed …

(Dave) #12

I assume you mean HobbyWing Xrotor, those will be fine.

There are several Flight Controllers with a smaller footprint than a Pixhawk but if you already have one… PixRacer, Matek, Holybro Kakute, Omnibus, etc.

(John Crawford) #13

Thanks… That correct… HobbyWing …not HobbyKing… Pretty much done with RadioLink… I asked them a question days ago and they got back to me sending the MiniPix manual which does not answer my question in the first place.

As I told them I’m selling everything that has RadioLink on it. I’m pretty pissed off with their wishy washy ways. And I have quite a few of their products.

In the 1990’s I came close to dumping Futaba for the same crappy service. But the stepped up to the plate and started supporting their customers.

(John Crawford) #14

After removing the MiniPix and installing a PixHawk … I now have logs … Never could pull any logs from MiniPix … However if someone sees what the issue is please let me know … It still likes to flip… forward and sideways. Had to order a new set of landing legs because these have just about had enough abuse …LOL.

SEE ATTACHED 1st Flight & 2nd Flight

1 12-31-1979 6-00-00 PM.bin (866.5 KB)

2 12-31-1979 6-00-00 PM.bin (773.6 KB)

(John Crawford) #15

Had a fairly successful flight … Wanted to uploading latest log but the size will not allow me to upload … I tried to zip (compress) the Bin file but could not upload… Any ideas how I can shorten it to get it posted?

(Jakob Schmidt) #16

use a cloud type file sharing service like dropbox.

(John Crawford) #17

Ok Jakob … I believe I have it … See if you can view the bin file in Dropbox

https://www.dropbox.com/s/bbmdudiu3djsnht/log_2_2019-7-8-12-21-32.bin?dl=0

(Shawn) #18

Hi John,
Are you doing acrobatics with this quad? The RCout channels (signals from autopilot to ESC;s for motor control) are all over the place, some going to max and some going to minimum. Either very aggressive flying, or there’s a fair imbalance of centre of gravity or shifting weight - just my initial thoughts.
Roll seems to be following Desired roll reasonably, but Pitch and Desired pitch are all over the place - something going on the there with the weight distribution or tuning.

(John Crawford) #19

Hi Shawn …
YUP! that was the issue … it was going all over the place and I would fight it in flight… I’m not into aerobatics with the quads … but this was a handful … Did some adjustments to my TX not having the latest upgrade …
Today I took it out and did an AUTOTUNE and all looks good … It’s now becoming more and more stable … I believe it is needing some minor tweaking in MP… I’ll upload another Data BIN file later tonight with a video of its flight … I did hit it hard (full throttle) after the AUTOTUNE on forward flight and the motors didn’t even get warm nor did the ESCs…

Did you happen to retrieve the DATA from the Dropbox by any chance?

(Shawn) #20

Yes, i got the log from the latest Dropbox link above.