Quad Drifts during POS hold mode, it happends the moment I stop giving any input to the system

The quad drifts in the POS hold mode as if it is trying hard to hold a position but every time it overshoots to the opposite direction. I tried a different set of PID values but the problem still exist. My CCW are about 100PWM higher that CW motor. I use Elmid m2 as my Primary(and only) GPS, the data update rate is 10hz. Please give me some suggestion to get a stable flight

Read and follow the documentation. There could be a lot wrong with your setup.

That link has an access requirement.

ohh, I am Sorry
i will update it

(post deleted by author)

Everything else is carefully designed and manufactured, Just one defect I could find out is the motor is slight tilted.

A high value for stabilize roll gain can cause this effect over responsiveness?
I feel it fairly does a good job until the position control kicks in.

Am I to assume you did the Alt-A calibration in mission planner, and set-up the dynamic notch filter, and checked that the vibration levels are ok?

Do you have a log of normal flight rather than 25 take-off attempts? In those attempts it looks like it has insufficient thrust with an average commanded motor output of ~1700µs. Should be ~1500 at hover.

This flight was done with different values of P and D to check if there is any improvement. But unfortunately there isn’t.
No, I don’t have log in which i attempted POS Hold before. It was doing well for waypoint missions, So never tried the POS. Lately I noticed it just drift around while take off and land.
Attaching the last waypoint mission log file.

No, I haven’t doe that, the vibration levels are looks good even in the forward flight at 8m/s.