Quad begins to move up when switching from loiter to Stabilize

Can somebody review and advice on the subject issue? link to bin file…

The landing is a bit rough…

Best Regards

Have you followed my guide to methodically tune ArduCopter? You should.

1 Like

Looks like you got thru the Initial Tune Parameters and stopped there. Plenty of tuning left to go.

Here is a direct link in case you can not find it:

It explains that Initial Tune Parameters is the beginning of the configuration, not the end. Lots of steps are missing, some even before the initial tuning!

Many Thanks for such a good guide.

Attached is the latest log file. I enabled the RAW IMU option before flight. Also put a heavier 4S 4000mah battery, so now MOT_THST_HOVER is above 0.2. I tried to open it in online filter analyzer but it failed. Did i miss something?
Another thing noted that the alt values in GPS are not matching with baro alt values. Baro values looks ok but GPS alt is confusing. Is this normal?

Apologies for any stupid question as quite new to quad tuning.

here is bin file link…

Best Regads

Re-try opening it. It must work.

baro alt is relative to home. GPS alt is AMSL

still not opening…
says Uncaught TypeError…(reading sample time)…line 2802

I understand GPS is AMSL but the pattern should be same as baro alt. It starts at 214, then at midway drops to 210 and ends at 206.

What’s not opening? Opening with what?

I guess he is trying to open the .bin file in the online filter analyzer. But if the LOG_BITMASK is set incorrectly he will have no data.

So I guess he is still not following the Blog post, and is going around in circles… instead of following the steps. The .param files in the blog post contain all the parameters he needs.

Or this:

You can use the default Log Bitmask but if the batch sampler isn’t enabled no log analyzer is going to work for filter data.

Thanks, batch sampler was not enabled.