Servers by jDrones

Quad becomes unstable after mid-mission-land and takeoff again


(Jesper Andersen) #1

I’ve searched for similar issues but haven’t really been able to find anything even though this seems like a firmware bug that somebody else should have encountered.

I’ve created a waypoint mission like this, with a land and takeoff sequence in the middle of the mission(used for deliveries etc…):

  1. Takeoff
  2. Waypoint 1
  3. Waypoint 2
  4. Land
  5. Takeoff
  6. Waypoint 3
  7. Land

Once in auto mode everything starts out fine. But when times come for the quad to fly to waypoint 3 (item 6) after it has landed and taken off again - the navigation becomes unstable, with the quad doing bigger and bigger circles (extreme toilet bowling). If I flip it back in poshold I can usually bring it to land but it’s still affected and want’s to fly in circles.
If I don’t have a land and takeoff waypoint in the middle of my mission (remove item 4 and 5) - everything is fine, so it seems that something gets screwed up by having a land and takeoff sequence inside the mission.
I’m not sure the arducopter software was intended to have in the middle land and takeoff again, but shouldn’t it be possible.
I’m using an APM 2.8 with external GPS and compass and the versoin 3.2.1 arducopter software, and all other waypoint missions work perfectly. Could it be that while the copter is on the ground during item 4 and 5, the inertial system becomes unstable because of the copter standing on the ground with motors spinning?


(Mike Boland) #2

Can you post a log file from the mission.

I can’t say much from your description other than agree with what you have observed.
Toilet bowling is usually a clear indicator of a compass problem.

Would be able to tell more, I hope, from your FC log files.


(Jesper Andersen) #3

Hi Mike

Thank you so much for your reply - I’ve uploaded two logs - they probably show the same thing as they are from 2 executions of the same mission. If you look at the barometer alt, you’ll see that approximately halfway through the mission, the copter lands, then takes off again - it’s after this that things go south. The takeoff itself seemed fine but once the copter starts to fly towards the next waypoint - it starts to become increasingly unstable.
On both occasions I had to resume control and was able to get it down, not pretty, but in one piece.

2017-07-14 08-01-36.bin (462 KB)
2017-07-14 07-55-49.bin (495.5 KB)


(Mike Boland) #4

You ran out of power.
You had a Battery Failsafe early in the flight but kept flying.
What you observed is what happens when your motors no longer have the power to fly.


(Jesper Andersen) #5

Hi Mike - thank you very much for taking the time!
Thats a nice way of plotting key metrics from the log - what tool is that?

Your conclusion seems logical however - I ran a new test today with a fully charged battery and the issue happened almost right away after starting a very minimalistic mission - it didn’t even get to land before it happened.
I was again able to regain control and I learned that if i tried gentle corrects to get the quad back to my landing zone, the quad would kind of fight me, and continue the big bowling motion - but if I did some very harsh corrections (hard left, hard right, hard foreward and hard backward) the quad would eventually come back to it’s good old self. I then had it hovering gently for almost 7 minutes without any problems and with juice left on the battery.

When I tried to recover the logfile, something went wrong (got a corrupted message) - in essence, I couldn’t recover the file…

I’ll try again tomorrow. I’m suspecting a brownout maybe? Will try a different power module for the APM.

Thanks again :smile:

-Jesper