Servers by jDrones

QGroundControl on Mac won't connect to Pixhawk via SiK


(Mike Close) #1

This is my first Pixhawk build. If there is a simple solution to this, I’m sorry, I swear I’ve done a lot of searching.

Stack:
Holybro Pixhawk runing Arduplane 3.9.1
Holybro 915mhz SiK radios with factory firmware
Mac OS 10.13.6
QGroundControl 3.4.2

System Information says the radios are manufactured by FTDI.
I have installed the Serial USB drivers from FTDI on the Mac.
When I plug the radio into the Mac, it appears to be communicating - when I turn heartbeat on and off in QGC, the radio’s leds reflect the change.
The radio connected to the Mac is flashing green, flashing red, and doing a double orange flash.
The radio attached to the Pixhawk is flashing red, no green led, no orange led.
I can connect to the Pixhawk via USB, but I can’t connect via SiK.

I’m guessing that the problem is with the Pixhawk’s radio, because it doesn’t appear to be searching for another radio? I’ll keep scouring the web for solutions, but any advice would be greatly appreciated!

-Mike


(Mike Boland) #2

It does sound like a bricked or faulty radio.
Normally when both are powered up they will just connect with a solid green led.
Have you tried connecting the radio currently connected to the Pixhawk, to the Mac?
QGroundControl can do the firmware on these radios so it might be an option before returning it to the supplier.


(Mike Close) #3

Thanks Mike. I had a feeling it was something like that - there isn’t a lot of help for this problem out there, which made me think that it usually just works. I haven’t tried the radio that was on the Pixhawk over on the Mac yet, but I’m doing that right now. Everything is set to go into the aircraft as soon as I get these radios figured out. I’ll try updating the firmware on the radio too.


(Mike Close) #4

I flashed the firmware on both radios and… voila! It works. Thank you again, Mike, for confirming that there was no configuration I was missing and suggesting the firmware update!