Servers by jDrones

QGroundControl on Android tablet not fully loading parameters

(Marc Segond) #1

Hi There.
I am running QGroundControl on a Huawei android tablet (a quite recent one, with the latest OS from Huawei).
I connect my radio to the micro USB port using the cable that comes with the radio (the one with a T at one end).
When I connect to the quad, it starts to load the list of parameters but always stays stuck at the very end and ends up with the message that the full list of parameter was not loaded.
Strange thing: when I use the same radio but connected on a PC (Windows10) it loads without problems on both QGroundControl and MissionPlanner.

Anybody has an idea about what is happening?

Another question, just for curiosity: why does connecting to the tablet only work with the provided micro USB to micro USB cable (the one with the T connection at one end), and putting the T connector on the end of the tablet? Is there anything special with this cable? I tried with others and the tablet was never able to communicate with the radio.

Edit: I understand that’s an OTG cable right? And my other cables are just data cables…

(DonLakeFlyer) #2

Check your packet loss rate for Mavlink from QGC Settings/Mavlink page. You might be getting a lot of noise from the tablet killing the radio.

(Marc Segond) #3

Thanks, I’ll have a look to seeing it is the problem.
But if I have noise, wouldn’t it affect the radio during all the flight?
Because although the parameters don’t load, QGroundControl works and I can read the telemetry perfectly.

(DonLakeFlyer) #4

Yes it does. But you probably won’t notice that your telemetry is actually streaming at slower rates then it should be because it is losing packets. Since telemetry is only vehicle->gcs and is repeatedly sent you don’t notice noisy commns unless it gets really bad. That’s doesn’t necessarily mean it’s a good idea to fly in that state.

Whereas something like the parameter download relies on a communication protocol sequence between the vehicle and gcs. QGC does retry things 5 times but if it is really noisy the back/forth protocol may still fail.

QGC differs here with respect to Mission Planner. MP just keeps trying to download parameters until you cancel if it never finishes. At least I think that is how it works. Whereas QGC retries would should be a reasonable number of times and then fails. With the thinking being if the comm pipe is that bad it’s better to fail than give a false sense of goodness.

(Chris Olson) #5

There is a difference in tablets. With my previous tablets that just had micro-USB and had to use a OTG cable I had problems with this, and with lack of proper voltage to the telemetry radio.

When we bought new tablets we got 14" ones with full-size USB ports (it also has a micro-USB), plus hardware keyboard and mousepad (also USB device but with a special “docking port” on the bottom of the tablet). The new tablets are 100% trouble free on downloading all the params, and they supply proper 5V to the telemetry radio.

(Jeff) #6

@Marc_Segond

Are you able to connect the FC directly to the tablet via a USB cable and load the parameters that way? In theory that might rule out a radio problem as opposed to a serial port problem.

(Marc Segond) #7

Hi all.
Thanks for your help!
@xbnr99, I have just tried to connect my tablet to the Pixhawk directly using the USB cable. I does load all the parameters without any problem. The only thing though is that it looses communication with the Pixhawk after 2 or 3 minutes. always. I am not sure if it might be my tablet that doesn’t output sufficient power to maintain the link…or if it is something else.
But, as you said, it seems that the parameters loading problem is linked to the radio link.
I won’t be able to test it for a week, but when I am back, I will monitor the errors on the radio link.

(Marc Segond) #8

@DonLakeFlyer thanks for this explanation. In a week I’ll be able to monitor the radio link quality and then I might know better what happens.
What can make a tablet kill so badly a radio link? When I use the very same radio with my laptop, it work perfectly.

(Chris Olson) #9

The USB Host mode in your tablet is likely not supplying adequate power to the radio. It might be something as simple as wiring up an external power supply for your telemetry radio.

Edit: What works quite nicely for an external power supply is to split the power and ground wires out of the OTG cable and use one of those little USB battery packs that folks use to charge cell phones on the go.

1 Like
(James Miller) #10

I’m having the same problem- unable to finish downloading the parameters from the aircraft on my tablet.
If it’s power, one could indeed strip out the wires for power and ground, and supply power from some other source, butI have no idea which wires to select, and that seems a kinda crude solution. Is there a “y” cable available? Seems like an in-line power booster would be a good product for small host devices on android.
If the problem is noise from the tablet or host device, how might one quiet it down?

(Jeff) #11

An OTG hub may also work, and there’s no wiring involved. Note that there are three ports for USB and one for power.

https://www.ebay.com/p/4-in-1-Micro-USB-Hub-OTG-Charging-Cable-Extension-Adapter-Android-Samsung-Tablet/1082097250?iid=223507656171&rt=nc