Qground Control Sequence Error

When you first connected the app it should have been updated (you should have gotten a popup).

The bad logging thing, I think, was a software bug but didn’t affect performance.

Your wife is great! Mine just bought me a Nintendo Switch, which works because my 6 year old can’t fly drones with me yet.

Also, she shoulda waited till the Journey was released lol Of course that could still be a few months…but hopefully not.

1 Like

Tower worked this morning! Full Auto mission. Parameters as shown above. .

1 Like

That’s good to hear , I wonder did Tower app get an update ?

no it hasn’t been updated in over 6 months i think. dev doesn’t work on it anymore. Or dronekit-android which it uses. I made a PR against it trying to fix follow-me, and it is just sitting there.

1 Like

If anyone knows the SkyViper folks and they are interested in sending me one I can look to see what is going on with QGC and mission uploads.

1 Like

Don I would consider sending you my flight board and sonic , to check out. But I wanted to see if I could transplant those in to a frame with matching props and gear mounts and 8x20 brushed motors , I’ll post a pic of quad I’m talking about got it in 2014 for around $50 cdn.adding photo https://www.facebook.com/photo.php?fbid=10157253320004937&set=pob.549259936&type=3
One in upper right corner . Is a good stable flyer , motors getting weak though and range is sketchy beyond 50 m

1 Like

New viper has arrived . I now have 4 1200mah batteries whoohoo! Now to see if I can get a mission to work

Auto-mode missions are working pretty well in Tower. Parameters are as posted above. Flight distances from Home far exceed the range of manual flights. Still experimenting with Actions (camera trigger etc.) but it flies and the Tx camera/video buttons work, so that’s a start. Next, back to experimenting in Q…

Update , I was able to get Tower on Android conected to Skyviper at last . Seems what I was doing wrong was turning on the controller /tx . That must be off . Not sure why that is but it works.
Also new viper arrived had a bad pinion on one motor looks like a quality con troll issue teeth never got formed on part when molded or milled how ever they make them little nylon gears . Thankfully good pinions on my broken frame so shaped oout.

@OlivierB I’ve started testing with the SkyViper you sent me. So far I think it may just be that the WiFi link is really noisy which in turn causes the Mission protocol to fail. Still looking…

Another question: Has anyone gotten the video to play through to QGC?

1 Like

With respect to video I am not sure I ever tried, but seem to remember others have been unsuccessful.

Donlakeflyer I don’t believe any one has been able to get video from sonic to either Qground or Tower not sure about any others . Would be nice if it could be done.

Same problems here. Video is working (rtsp://

Finally had time to dig into this. If you want the gory details look here: https://github.com/mavlink/qgroundcontrol/pull/6718. Otherwise wait for a new QGC daily build (in an hour or so) and mission upload should be significantly better. Still not 100% foolproof since the SkyViper WiFi is incredibly noisy with huge packet loss. So you still may need to retry once in a while.

Thanks OlivierB for sending my his SkyViper so I could test.

1 Like

@DonLakeFlyer , thanks for working on this , I tried down loading Qground daily build first of the week hoping that it might work for me now ,. Unfortunately :disappointed_relieved::pensive: , it seemed to make connection drop repeatedly with in 10 seconds of connecting. .

Correction to above , tried again to connect using Qgc and it worked no issue up loadding even had video stream all though badly mostly grey screen with a video shot 2 or 3 times a sec.
Update it looks like camera on sv only activates if it sees motion . If I pick up frame and move video is clear and steady . Stop and it goes back to grey and funky . If I walk in front of camera it will show me but not back ground . Strange things ,strange things…

I get that reply on my iPhone and my Android won’t hook up to it. Any ideas??

Hi Joe!

Thanks sounds… odd. Very odd.

Let me know if you want me to send you out a new (used, but from my desk) Video card. It sounds like yours may have connection issues on the sensor cable.

  • Matt
1 Like

Same issue had been solved by formated SD card.

1 Like